# Coupled task failure

**URL:** <https://cms-helpdesk.ncas.ac.uk/t/coupled-task-failure/920>\
**Category:** Unified Model\
**Tags:** ARCHER2, PUMATest\
**Created:** [20 February 2023 13:30 UTC](https://cms-helpdesk.ncas.ac.uk/t/coupled-task-failure/920 "2023-02-20T13:30:07Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![racheldiamond](https://avatars.discourse-cdn.com/v4/letter/r/eb9ed0/32.png) [@racheldiamond](https://cms-helpdesk.ncas.ac.uk/u/racheldiamond)\
**Post date:** [20 February 2023 13:30 UTC](https://cms-helpdesk.ncas.ac.uk/t/coupled-task-failure/920/1 "2023-02-20T13:30:07Z")

</div>

Hi,

I was running HadGEM3-GC3.1-LL, suite u-cr613, and the model failed in coupled task 23060701T0000Z because my disk quota was exceeded. I cleared disk space and retriggered the task, but this failed again with errors like

???  
???!!!???!!!???!!!???!!!???!!! ERROR ???!!!???!!!???!!!???!!!???!!!  
? Error code: 4  
? Error from routine: STWORK  
? Error message: STWORK: Number of fields exceeds reserved headers for unit 28  
? Error from processor: 22  
? Error number: 37  
???

How should I fix the issue? The model ran fine for about 50 years before the disk quota was exceeded. I notice there are several size 0 files - e.g. cylc-run/u-cr613/share/data/History\_Data/cr613a.pv2306jun - is the problem related to this?

Best wishes,

Rachel

---

<div class="post-metadata">

**Author:** ![racheldiamond](https://avatars.discourse-cdn.com/v4/letter/r/eb9ed0/32.png) [@racheldiamond](https://cms-helpdesk.ncas.ac.uk/u/racheldiamond)\
**Post date:** [21 February 2023 11:42 UTC](https://cms-helpdesk.ncas.ac.uk/t/coupled-task-failure/920/2 "2023-02-21T11:42:25Z")

</div>

Hi,

Unit 28 is assigned to output file pp2, so (as in the NCAS training exercises) on PUMATest in roses/u-cr613/app/um/rose-app.conf I’ve changed reinit\_step from 90 to 60:

file\_id=‘pp2’  
!!filename=‘$ROSE\_DATAC/$RUNID.pp2’  
filename\_base=‘$DATAM/${RUNID}a.pc%C’  
l\_reinit=.true.  
packing=5  
reinit\_end=-1  
reinit\_start=0  
reinit\_step=60  
reinit\_unit=2  
reserved\_headers=32000

I reloaded the suite, and re-triggered coupled task 23060701T0000Z. However, the model now fails with new error:

???  
???!!!???!!!???!!!???!!!???!!! ERROR ???!!!???!!!???!!!???!!!???!!!  
? Error code: 4307  
? Error from routine: CHECK\_IOSTAT  
? Error message:  
? Error reading namelist NLSTCALL\_PP  
? IoMsg: Incorrect namelist input variable “REINIT\_STEP” or mismatched input value.  
? Please check input list against code.  
? Error from processor: 0  
? Error number: 0  
???

Do you have any idea about how to fix the original problem?

Best wishes,

Rachel

---

<div class="post-metadata">

**Author:** ![grenville](https://dub1.discourse-cdn.com/flex013/user_avatar/cms-helpdesk.ncas.ac.uk/grenville/32/29_2.png) [@grenville](https://cms-helpdesk.ncas.ac.uk/u/grenville)\
**Post date:** [23 February 2023 14:43 UTC](https://cms-helpdesk.ncas.ac.uk/t/coupled-task-failure/920/3 "2023-02-23T14:43:50Z")

</div>

Hi Rachel

I don’t understand why the model decided that _Number of fields exceeds reserved headers for unit 28_ after running OK for 5 years.

I no longer see the error: `IoMsg: Incorrect namelist input variable “REINIT_STEP” or mismatched input value` in the output log, but the model has `reinit_step=60`.

So, I’m not sure what is going on?

Grenville

---

<div class="post-metadata">

**Author:** ![racheldiamond](https://avatars.discourse-cdn.com/v4/letter/r/eb9ed0/32.png) [@racheldiamond](https://cms-helpdesk.ncas.ac.uk/u/racheldiamond)\
**Post date:** [23 February 2023 16:40 UTC](https://cms-helpdesk.ncas.ac.uk/t/coupled-task-failure/920/5 "2023-02-23T16:40:27Z")

</div>

Hi Grenville,

Yesterday, I switched reinit\_step back to 90 and retriggered the task so I could see the original problem again. I’m not sure why reinit\_step=60 now, maybe I didn’t save it correctly?  
If it’s helpful, I can retrigger the task again with reinit\_step=60, so you can see the error `IoMsg: Incorrect namelist input variable “REINIT_STEP” or mismatched input value`.

Best wishes,

Rachel

---

<div class="post-metadata">

**Author:** ![grenville](https://dub1.discourse-cdn.com/flex013/user_avatar/cms-helpdesk.ncas.ac.uk/grenville/32/29_2.png) [@grenville](https://cms-helpdesk.ncas.ac.uk/u/grenville)\
**Post date:** [23 February 2023 17:00 UTC](https://cms-helpdesk.ncas.ac.uk/t/coupled-task-failure/920/6 "2023-02-23T17:00:44Z")

</div>

ah, OK – as a work around try increasing the reserved\_headers to 50000 (leave reint\_step at 90 days)

---

<div class="post-metadata">

**Author:** ![racheldiamond](https://avatars.discourse-cdn.com/v4/letter/r/eb9ed0/32.png) [@racheldiamond](https://cms-helpdesk.ncas.ac.uk/u/racheldiamond)\
**Post date:** [23 February 2023 17:46 UTC](https://cms-helpdesk.ncas.ac.uk/t/coupled-task-failure/920/7 "2023-02-23T17:46:55Z")

</div>

Hi,

Thanks, I just tried that but still get the error message -  
STWORK: Number of fields exceeds reserved headers for unit 28.

Best wishes,

Rachel

---

<div class="post-metadata">

**Author:** ![RosalynHatcher](https://dub1.discourse-cdn.com/flex013/user_avatar/cms-helpdesk.ncas.ac.uk/rosalynhatcher/32/11_2.png) [@RosalynHatcher](https://cms-helpdesk.ncas.ac.uk/u/RosalynHatcher)\
**Post date:** [19 May 2023 15:04 UTC](https://cms-helpdesk.ncas.ac.uk/t/coupled-task-failure/920/8 "2023-05-19T15:04:51Z")

</div>


