# Failed to complete test.platform.c8

**URL:** <https://cms-helpdesk.ncas.ac.uk/t/failed-to-complete-test-platform-c8/1451>\
**Category:** Rose/Cylc and FCM\
**Tags:** ARCHER2\
**Created:** [19 June 2024 09:29 UTC](https://cms-helpdesk.ncas.ac.uk/t/failed-to-complete-test-platform-c8/1451 "2024-06-19T09:29:10Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![markr](https://avatars.discourse-cdn.com/v4/letter/m/e68b1a/32.png) [@markr](https://cms-helpdesk.ncas.ac.uk/u/markr)\
**Post date:** [19 June 2024 09:29 UTC](https://cms-helpdesk.ncas.ac.uk/t/failed-to-complete-test-platform-c8/1451/1 "2024-06-19T09:29:10Z")

</div>

Hello,  
I am trying to follow the advice on test.platforms.c8. I have confirmed the puma2 setup works:  
$ rose host-select archer2  
ln02  
I did set CYLC\_VERSION=8  
However the archer2\_bg task failed. Of course the localhost\_bg worked. and the third task (jasmin sci8?) did not start. [I have never tried to jasmin from archer2]

~mricha/cylc-run should be readable.

any suggestions welcome. I hope it is a straightforward solution.

Mark

---

<div class="post-metadata">

**Author:** ![grenville](https://dub1.discourse-cdn.com/flex013/user_avatar/cms-helpdesk.ncas.ac.uk/grenville/32/29_2.png) [@grenville](https://cms-helpdesk.ncas.ac.uk/u/grenville)\
**Post date:** [19 June 2024 15:25 UTC](https://cms-helpdesk.ncas.ac.uk/t/failed-to-complete-test-platform-c8/1451/2 "2024-06-19T15:25:36Z")

</div>

Mark

Did it fail repeatedly?

Grenville

---

<div class="post-metadata">

**Author:** ![jeff](https://dub1.discourse-cdn.com/flex013/user_avatar/cms-helpdesk.ncas.ac.uk/jeff/32/29_2.png) [@jeff](https://cms-helpdesk.ncas.ac.uk/u/jeff)\
**Post date:** [19 June 2024 16:36 UTC](https://cms-helpdesk.ncas.ac.uk/t/failed-to-complete-test-platform-c8/1451/3 "2024-06-19T16:36:42Z")

</div>

Can you log into ln01,ln02,ln04 and [sci8.jasmin.ac.uk](http://sci8.jasmin.ac.uk) from puma2 without being asked for any information (password etc.)?

---

<div class="post-metadata">

**Author:** ![markr](https://avatars.discourse-cdn.com/v4/letter/m/e68b1a/32.png) [@markr](https://cms-helpdesk.ncas.ac.uk/u/markr)\
**Post date:** [19 June 2024 18:14 UTC](https://cms-helpdesk.ncas.ac.uk/t/failed-to-complete-test-platform-c8/1451/4 "2024-06-19T18:14:56Z")

</div>

I think so. “submit failed”.

what is a cylc 8 command to reset and start a task in tui? (Sorry am at UKMO meeting so intermittent comms).

---

<div class="post-metadata">

**Author:** ![markr](https://avatars.discourse-cdn.com/v4/letter/m/e68b1a/32.png) [@markr](https://cms-helpdesk.ncas.ac.uk/u/markr)\
**Post date:** [19 June 2024 18:21 UTC](https://cms-helpdesk.ncas.ac.uk/t/failed-to-complete-test-platform-c8/1451/5 "2024-06-19T18:21:36Z")

</div>

Hi Jeff,  
well I thought it would be unlikely as it is quite a palaver just to login from a standard university system. I can confirm ssh [sci8.jasmin.ac.uk](http://sci8.jasmin.ac.uk) does not work from ln02.

I always have to go to [login2.jasmin.ac.uk](http://login2.jasmin.ac.uk) and use 2FA and use my jasmin user-id (not same as any of my archer2 ids.) I did try ssh -l jasmin\_id [sci8.jasmin.ac.uk](http://sci8.jasmin.ac.uk) as well.

I am not particular worried about jasmin as I have not read any doc guidance on doing that. it just happens tobe part of Annettes test suite.

I wonder why the archer2\_bg did not work when I have proved for myself that I can run a standard UM 13.2 suite okay.  
Does it need CYLC\_VERSION=8 on the lnXX node?

Mark

---

<div class="post-metadata">

**Author:** ![jeff](https://dub1.discourse-cdn.com/flex013/user_avatar/cms-helpdesk.ncas.ac.uk/jeff/32/29_2.png) [@jeff](https://cms-helpdesk.ncas.ac.uk/u/jeff)\
**Post date:** [20 June 2024 12:00 UTC](https://cms-helpdesk.ncas.ac.uk/t/failed-to-complete-test-platform-c8/1451/6 "2024-06-20T12:00:24Z")

</div>

Hi Mark

The error seems to be coming from this file `/home/n02/n02/mricha/cylc-run/test.platforms.c8/run1/log/scheduler/01-start-01.log`

```auto
2024-06-19T19:10:41+01:00 ERROR - platform: ln01_bg - initialisation did not complete
    COMMAND:
        ssh -oBatchMode=yes -oConnectTimeout=8 \
            -oStrictHostKeyChecking=no ln01 env CYLC_VERSION=8.2.5 \
            CYLC_ENV_NAME=cylc-8.2.5-1 bash --login -c \
            'exec "$0" "$@"' cylc remote-init archer2 \
            $HOME/cylc-run/test.platforms.c8/run1 \
            run='$DATADIR/cylc-run/test.platforms.c8/run1'
    RETURN CODE:
        2
    STDERR:
        Usage: cylc [task] remote-init [--indirect-comm=ssh] UUID RUND
        (This command is for internal use.)
        Install suite service files on a task remote (i.e. a [owner@]host):
            .service/contact: All task -> suite communication methods.
            .service/passphrase: Direct task -> suite HTTP(S) communication only.
            .service/ssl.cert: Direct task -> suite HTTPS communication only.
        Content of items to install from a tar file read from STDIN.
        Return:
            0:
                On success or if initialisation not required:
                - Print SuiteSrvFilesManager.REMOTE_INIT_NOT_REQUIRED if initialisation
                  not required (e.g. remote has shared file system with suite host).
                - Print SuiteSrvFilesManager.REMOTE_INIT_DONE on success.
            1:
                On failure.
        Arguments:
           UUID UUID of current suite server process
           RUND The run directory of the suite
        cylc-remote-init: error: Wrong number of arguments (too many)

```

I’m not sure why you get this error, someone with more cylc8 knowledge will have to look at it.

Jeff.

---

<div class="post-metadata">

**Author:** ![markr](https://avatars.discourse-cdn.com/v4/letter/m/e68b1a/32.png) [@markr](https://cms-helpdesk.ncas.ac.uk/u/markr)\
**Post date:** [20 June 2024 14:42 UTC](https://cms-helpdesk.ncas.ac.uk/t/failed-to-complete-test-platform-c8/1451/7 "2024-06-20T14:42:23Z")

</div>

Hello Jeff and Grenville,  
I just had some great local support. It seems I missed a step in the PUMA2 setup because I already have .bash\_profile. I should have looked closer - I now have  
. /work/y07/shared/umshared/bin/rose-um-env-puma2  
on archer login account.

basic error on my part, sorry. Thanks for looking.  
Mark
