# Postproc\_nemo failure out of memory

**URL:** https://cms-helpdesk.ncas.ac.uk/t/postproc-nemo-failure-out-of-memory/1116
**Category:** Unified Model
**Tags:** ARCHER2
**Created:** [1 September 2023 09:44 UTC](https://cms-helpdesk.ncas.ac.uk/t/postproc-nemo-failure-out-of-memory/1116 "2023-09-01T09:44:48Z")
**Posts on this page:** 1
**Showing post:** 6

<div class="post-metadata">

### Author: ![sebsteinig](https://avatars.discourse-cdn.com/v4/letter/s/898d66/32.png) [@sebsteinig](https://cms-helpdesk.ncas.ac.uk/u/sebsteinig)
#### Post date: [6 October 2023 13:13 UTC](https://cms-helpdesk.ncas.ac.uk/t/postproc-nemo-failure-out-of-memory/1116/6 "2023-10-06T13:13:49Z")

</div>

UPDATE: problem solved!

The ARCHER2 Helpdesk got back to me and said they applied a patch to the Lustre filesystem over the past few days.

I tested this with several suites and the postproc now seems to be running fine again on the serial nodes! One additional thing I had to to do was to request a bit more memory for the postproc jobs (the default is just below 2GB). 10 GB works fine for me, but I did not test other values.

If anybody runs into the same OOM error, I just added the memory request to the postproc resources in the `archer2.rc` configuration:

```auto
    [[POSTPROC_RESOURCE]]
        inherit = HPC_SERIAL
        pre-script = """
                     module load postproc
                     module list 2>&1
                     ulimit -s unlimited
                     """
        [[[directives]]]
            --mem=10G

```

Best wishes,  
Seb

---

_[View the full topic](https://cms-helpdesk.ncas.ac.uk/t/postproc-nemo-failure-out-of-memory/1116)._
