# Pp\_transfer error

**URL:** <https://cms-helpdesk.ncas.ac.uk/t/pp-transfer-error/1692>\
**Category:** Unified Model\
**Tags:** ARCHER2\
**Created:** [22 April 2025 09:29 UTC](https://cms-helpdesk.ncas.ac.uk/t/pp-transfer-error/1692 "2025-04-22T09:29:19Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![andreadittus](https://dub1.discourse-cdn.com/flex013/user_avatar/cms-helpdesk.ncas.ac.uk/andreadittus/32/461_2.png) [@andreadittus](https://cms-helpdesk.ncas.ac.uk/u/andreadittus)\
**Post date:** [22 April 2025 09:29 UTC](https://cms-helpdesk.ncas.ac.uk/t/pp-transfer-error/1692/1 "2025-04-22T09:29:19Z")

</div>

Hi,

I have a new suite, u-dl797, with the following pp\_transfer error:

Traceback (most recent call last):  
File “/work/n02/n02/adittus/cylc-run/u-dl797/share/fcm\_make\_pp/build/bin/transfer.py”, line 448, in   
main()  
File “/work/n02/n02/adittus/cylc-run/u-dl797/share/fcm\_make\_pp/build/bin/transfer.py”, line 425, in main  
transfer = Transfer()  
File “/work/n02/n02/adittus/cylc-run/u-dl797/share/fcm\_make\_pp/build/bin/transfer.py”, line 48, in **init**  
self.\_globus\_cli = nl\_transfer.globus\_cli  
AttributeError: ‘ReadNamelist’ object has no attribute ‘globus\_cli’

Initially pp\_transfer failed due to lack of disk space, now resolved (I freed up ~1TB), but it is now failing with the error above.

This suite is a modified copy of u-dj147, where pp\_transfer worked previously with globus.

Any suggestions very welcome!

Thanks,  
Andrea

---

<div class="post-metadata">

**Author:** ![Juan\_Bilbao](https://dub1.discourse-cdn.com/flex013/user_avatar/cms-helpdesk.ncas.ac.uk/juan_bilbao/32/458_2.png) [@Juan\_Bilbao](https://cms-helpdesk.ncas.ac.uk/u/Juan_Bilbao)\
**Post date:** [22 April 2025 10:46 UTC](https://cms-helpdesk.ncas.ac.uk/t/pp-transfer-error/1692/2 "2025-04-22T10:46:10Z")

</div>

Hi Andrea,

I took a look at the file `/home/n02/n02/adittus/cylc-run/u-dl797/app/postproc/rose-app.conf` and also the working suite `u-dj147`. The file is still configured to use `Gridftp` which has been retired.

You can set this  
`gridftp=false`

And add these lines:

```auto
globus_cli=true

```

```auto
globus_default_colls=true

```

```auto
globus_notify='off'

```

and comment out these lines:

```auto
!globus_cli=true

```

```auto
!globus_default_colls=true

```

```auto
!globus_notify='off'

```

In the u-dj147 (working suite) you had this configuration:

```auto
[namelist:pptransfer]

delete_staged=false

gridftp=false

gridftp_cc_opt=4

gridftp_verify_opt=true

remote_host=gridftp1.jasmin.ac.uk

transfer_dir=/work/xfc/vol5/user_cache/adittus/stabilisation

transfer_type=Push

verify_chksums=false

globus_cli=true

globus_default_colls=true

globus_notify='off'

```

Hopefully it works, after the changes.

Best regards,  
Juan

---

<div class="post-metadata">

**Author:** ![andreadittus](https://dub1.discourse-cdn.com/flex013/user_avatar/cms-helpdesk.ncas.ac.uk/andreadittus/32/461_2.png) [@andreadittus](https://cms-helpdesk.ncas.ac.uk/u/andreadittus)\
**Post date:** [22 April 2025 11:16 UTC](https://cms-helpdesk.ncas.ac.uk/t/pp-transfer-error/1692/3 "2025-04-22T11:16:07Z")

</div>

Hi Juan,

Thank you!

Oddly enough, I checked this exact thing this morning, but on suite u-dj147 which is the parent suite and it was all ok. I thought because u-dl797 was a copy of u-dj147, if it is fine in one it would be in the other too, but did completely overlook that I copied u-dj147 _before_ the globus update revision in the trunk.

Thanks for pointing out my oversight… !

Cheers,  
Andrea

---

<div class="post-metadata">

**Author:** ![Juan\_Bilbao](https://dub1.discourse-cdn.com/flex013/user_avatar/cms-helpdesk.ncas.ac.uk/juan_bilbao/32/458_2.png) [@Juan\_Bilbao](https://cms-helpdesk.ncas.ac.uk/u/Juan_Bilbao)\
**Post date:** [22 April 2025 11:44 UTC](https://cms-helpdesk.ncas.ac.uk/t/pp-transfer-error/1692/4 "2025-04-22T11:44:53Z")

</div>

Happy to help!  
Best,  
Juan

---

<div class="post-metadata">

**Author:** ![Juan\_Bilbao](https://dub1.discourse-cdn.com/flex013/user_avatar/cms-helpdesk.ncas.ac.uk/juan_bilbao/32/458_2.png) [@Juan\_Bilbao](https://cms-helpdesk.ncas.ac.uk/u/Juan_Bilbao)\
**Post date:** [22 April 2025 11:45 UTC](https://cms-helpdesk.ncas.ac.uk/t/pp-transfer-error/1692/5 "2025-04-22T11:45:00Z")

</div>


