# Puma2 submit-failed

**URL:** <https://cms-helpdesk.ncas.ac.uk/t/puma2-submit-failed/1543>\
**Category:** Uncategorized\
**Tags:** ARCHER2\
**Created:** [23 October 2024 11:36 UTC](https://cms-helpdesk.ncas.ac.uk/t/puma2-submit-failed/1543 "2024-10-23T11:36:42Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![mo-marqh](https://dub1.discourse-cdn.com/flex013/user_avatar/cms-helpdesk.ncas.ac.uk/mo-marqh/32/441_2.png) [@mo-marqh](https://cms-helpdesk.ncas.ac.uk/u/mo-marqh)\
**Post date:** [23 October 2024 11:36 UTC](https://cms-helpdesk.ncas.ac.uk/t/puma2-submit-failed/1543/1 "2024-10-23T11:36:42Z")

</div>

Hi CMS

I have a new puma2 account and i have worked through the setup docs.  
i think i can ssh between puma2 and archer2 and svn to mosrs

however, when i try to run `lfric_atm` tests with cylc8 `rose stem` & `cylc play`  
my run fails,  
i’m getting

`state sumbit-failed` from `EXPORT-SOURCE` `remote-init_ex`

when i try to run a job from puma2

i can’t see any evidence that this has communicated with archer2, there is no  
`~/cylc-run`  
in my archer2 homespace

there’s almost no log information at  
`/home/n02/n02/marqh/cylc-run/lfric_apps_r4036/run1`

my colleagues have run these lfric\_atm tests, so i think the problem is with me

I’m not sure where to look to try and progress this.  
are you able to help me?  
thank you  
mark

---

<div class="post-metadata">

**Author:** ![grenville](https://dub1.discourse-cdn.com/flex013/user_avatar/cms-helpdesk.ncas.ac.uk/grenville/32/29_2.png) [@grenville](https://cms-helpdesk.ncas.ac.uk/u/grenville)\
**Post date:** [23 October 2024 11:57 UTC](https://cms-helpdesk.ncas.ac.uk/t/puma2-submit-failed/1543/2 "2024-10-23T11:57:15Z")

</div>

Hi Mark

Please allow us read permissions on your ARCHER2 home and work spaces, and on your puma2 space.

Grenville

---

<div class="post-metadata">

**Author:** ![mo-marqh](https://dub1.discourse-cdn.com/flex013/user_avatar/cms-helpdesk.ncas.ac.uk/mo-marqh/32/441_2.png) [@mo-marqh](https://cms-helpdesk.ncas.ac.uk/u/mo-marqh)\
**Post date:** [23 October 2024 12:01 UTC](https://cms-helpdesk.ncas.ac.uk/t/puma2-submit-failed/1543/3 "2024-10-23T12:01:16Z")

</div>

hi Grenville  
I think I’ve done this  
m

---

<div class="post-metadata">

**Author:** ![grenville](https://dub1.discourse-cdn.com/flex013/user_avatar/cms-helpdesk.ncas.ac.uk/grenville/32/29_2.png) [@grenville](https://cms-helpdesk.ncas.ac.uk/u/grenville)\
**Post date:** [23 October 2024 13:35 UTC](https://cms-helpdesk.ncas.ac.uk/t/puma2-submit-failed/1543/4 "2024-10-23T13:35:52Z")

</div>

Mark

`/home/n02/n02/marqh/cylc-run/lfric_apps_r4036/run1/log/scheduler/01-start-01.log`

says

```auto
2024-10-23T10:34:42Z WARNING - platform: ln03 - Could not connect to ln03.
...
2024-10-23T10:34:43Z WARNING - platform: ln04 - Could not connect to ln04.
  ...
2024-10-23T10:34:44Z WARNING - platform: ln02 - Could not connect to ln02.
  ...
2024-10-23T10:34:45Z WARNING - platform: ln01 - Could not connect to ln01.
 

```

which sounds like a setup problem. What happens if on puma2, you type

`rose host-select archer2`

Grenville

---

<div class="post-metadata">

**Author:** ![mo-marqh](https://dub1.discourse-cdn.com/flex013/user_avatar/cms-helpdesk.ncas.ac.uk/mo-marqh/32/441_2.png) [@mo-marqh](https://cms-helpdesk.ncas.ac.uk/u/mo-marqh)\
**Post date:** [23 October 2024 14:00 UTC](https://cms-helpdesk.ncas.ac.uk/t/puma2-submit-failed/1543/5 "2024-10-23T14:00:58Z")

</div>

```auto
[WARN] ln04: ssh failed
[WARN] ln03: ssh failed
[WARN] ln01: ssh failed
[WARN] ln02: ssh failed
[FAIL] No hosts selected.

```

---

<div class="post-metadata">

**Author:** ![mo-marqh](https://dub1.discourse-cdn.com/flex013/user_avatar/cms-helpdesk.ncas.ac.uk/mo-marqh/32/441_2.png) [@mo-marqh](https://cms-helpdesk.ncas.ac.uk/u/mo-marqh)\
**Post date:** [23 October 2024 15:24 UTC](https://cms-helpdesk.ncas.ac.uk/t/puma2-submit-failed/1543/6 "2024-10-23T15:24:09Z")

</div>

okay, i’ve tried to update some settings  
this was working previously but perhaps i broke something  
i can now

```auto
$ rose host-select archer2
ln02

```

but, with a new run:

```auto
/home/n02/n02/marqh/cylc-run/lfric_apps_r4036/run2/log/scheduler/01-start-01.log

```

i get

```auto
    STDERR:
        cylc: line 0: exec: cylc: not found

```

---

<div class="post-metadata">

**Author:** ![grenville](https://dub1.discourse-cdn.com/flex013/user_avatar/cms-helpdesk.ncas.ac.uk/grenville/32/29_2.png) [@grenville](https://cms-helpdesk.ncas.ac.uk/u/grenville)\
**Post date:** [23 October 2024 15:59 UTC](https://cms-helpdesk.ncas.ac.uk/t/puma2-submit-failed/1543/7 "2024-10-23T15:59:01Z")

</div>

Mark

create a .bash\_profile on ARCHER2 with

```auto

. /work/y07/shared/umshared/bin/rose-um-env-puma2

```

Grenville

---

<div class="post-metadata">

**Author:** ![mo-marqh](https://dub1.discourse-cdn.com/flex013/user_avatar/cms-helpdesk.ncas.ac.uk/mo-marqh/32/441_2.png) [@mo-marqh](https://cms-helpdesk.ncas.ac.uk/u/mo-marqh)\
**Post date:** [24 October 2024 14:33 UTC](https://cms-helpdesk.ncas.ac.uk/t/puma2-submit-failed/1543/8 "2024-10-24T14:33:05Z")

</div>

thanks Grenville

i hadn’t seen that instruction in the docs, so hadn’t implemented it

I also had some issues with ssh access, which i’ve got to the bottom of now, I think

I appear to have a test run running properly now  
thank you for your help  
mark

---

<div class="post-metadata">

**Author:** ![system](https://europe1.discourse-cdn.com/flex013/uploads/cms_support/original/1X/1fd2411499ffcbc299fe756cd5cdf26e44956558.png) [@system](https://cms-helpdesk.ncas.ac.uk/u/system)\
**Post date:** [23 November 2024 14:33 UTC](https://cms-helpdesk.ncas.ac.uk/t/puma2-submit-failed/1543/9 "2024-11-23T14:33:40Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
