# Submit-failed: puma2 to ARCHER2?

**URL:** <https://cms-helpdesk.ncas.ac.uk/t/submit-failed-puma2-to-archer2/2121>\
**Category:** Rose/Cylc and FCM\
**Tags:** ARCHER2\
**Created:** [7 July 2026 15:35 UTC](https://cms-helpdesk.ncas.ac.uk/t/submit-failed-puma2-to-archer2/2121 "2026-07-07T15:35:42Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![racheldiamond](https://avatars.discourse-cdn.com/v4/letter/r/eb9ed0/32.png) [@racheldiamond](https://cms-helpdesk.ncas.ac.uk/u/racheldiamond)\
**Post date:** [7 July 2026 15:35 UTC](https://cms-helpdesk.ncas.ac.uk/t/submit-failed-puma2-to-archer2/2121/1 "2026-07-07T15:35:42Z")

</div>

Hi,

I’m trying to use PUMA2 to run **UKCM2, suite id u-ea310**. Although the PUMA2 setup seems to be running ok, it gets submit-failed for all tasks that it tries to send to ARCHER2 (see screenshot).

**From puma2, I’ve checked:**

- my ssh agent is set up correctly with ssh-add -L
- the ARCHER2 to PUMA2 connection is ok using rose host-select archer2 (from [2. Getting Set Up (Self-Study Instructions) — NCAS Unified Model Introduction](https://ncas-cms.github.io/um-training/getting-setup-selfstudy.html#set-up-your-ssh-agent) )
- I have access to the relevant n02 budgets (n02-KANGGLAC and n02-SURFEIT) and there’s enough room, using SAFE.

I’m also attaching error logs.

 ![Screenshot 2026-07-08 105012](https://europe1.discourse-cdn.com/flex013/uploads/cms_support/original/1X/94ee4486700334ae97f999b591482b2066449665.png)

 ![Screenshot 2026-07-08 104947](https://europe1.discourse-cdn.com/flex013/uploads/cms_support/original/1X/7daea26e989e22c83699c7714f62afaedd0ce9df.png)

 ![Screenshot 2026-07-08 104927](https://europe1.discourse-cdn.com/flex013/uploads/cms_support/original/1X/961e9f5cd775e27a578dfae3f10289fc7b37c729.png)

 ![Screenshot 2026-07-07 163301](https://europe1.discourse-cdn.com/flex013/uploads/cms_support/original/1X/e8c02ee31a782d9ac612e7f2b8dbcedca52339ee.png)

 ![Screenshot 2026-07-07 154336](https://europe1.discourse-cdn.com/flex013/uploads/cms_support/original/1X/ab83662745d1944aad12bd447759da1bb55fe532.png)

Do you know what could be going wrong?

Thanks!

Rachel

Rachel

 ![Screenshot 2026-07-07 163301](https://europe1.discourse-cdn.com/flex013/uploads/cms_support/original/1X/e8c02ee31a782d9ac612e7f2b8dbcedca52339ee.png)

---

<div class="post-metadata">

**Author:** ![RosalynHatcher](https://dub1.discourse-cdn.com/flex013/user_avatar/cms-helpdesk.ncas.ac.uk/rosalynhatcher/32/11_2.png) [@RosalynHatcher](https://cms-helpdesk.ncas.ac.uk/u/RosalynHatcher)\
**Post date:** [8 July 2026 12:22 UTC](https://cms-helpdesk.ncas.ac.uk/t/submit-failed-puma2-to-archer2/2121/2 "2026-07-08T12:22:04Z")

</div>

Hi Rachel,

From the error message in the /home/n02/n02/radiam24/cylc-run/u-ea310/run1/log/scheduler/log file it looks like you’ve got a wonky cylc environment which is part cylc8 part cylc7.

This error message is the command help from Cylc7!

```auto
2026-07-07T15:16:51Z ERROR - platform: archer2 - initialisation did not complete
    COMMAND:
        ssh -oBatchMode=yes -oConnectTimeout=8 \\
            -oStrictHostKeyChecking=no ln02 env CYLC_VERSION=8.6.3 \\
            CYLC_ENV_NAME=cylc-8.6.3-2 bash --login -c \\
            'exec "$0" "$@"' cylc remote-init archer2 \\
            $HOME/cylc-run/u-ea310/run1 \\
            run='$DATADIR/cylc-run/u-ea310/run1'
    RETURN CODE:
        2
    STDERR:
        Usage: cylc \[task\] remote-init \[--indirect-comm=ssh\] UUID RUND
        (This command is for internal use.)
        Install suite service files on a task remote (i.e. a \[owner@\]host):
            .service/contact: All task -> suite communication methods.
            .service/passphrase: Direct task -> suite HTTP(S) communication only.
            .service/ssl.cert: Direct task -> suite HTTPS communication only.
        Content of items to install from a tar file read from STDIN
        Return:
            0:
                On success or if initialisation not required:
                - Print SuiteSrvFilesManager.REMOTE_INIT_NOT_REQUIRED if initialisation
                  not required (e.g. remote has shared file system with suite host).
                - Print SuiteSrvFilesManager.REMOTE_INIT_DONE on success.
            1:
                On failure.
        Arguments:
           UUID UUID of current suite server process
           RUND The run directory of the suite

```

I can’t see anything dodgey in your .profile.

Can you try:

- removing the `~/cylc-run/u-ea310` directory
- logout of puma2 and back in again
- export `CYLC_VERSION=8`
- `cylc --version`. # This should give you 8.6.3
- `cylc vip u-ea310`

Cheers,  
Ros

---

<div class="post-metadata">

**Author:** ![RosalynHatcher](https://dub1.discourse-cdn.com/flex013/user_avatar/cms-helpdesk.ncas.ac.uk/rosalynhatcher/32/11_2.png) [@RosalynHatcher](https://cms-helpdesk.ncas.ac.uk/u/RosalynHatcher)\
**Post date:** [8 July 2026 12:28 UTC](https://cms-helpdesk.ncas.ac.uk/t/submit-failed-puma2-to-archer2/2121/3 "2026-07-08T12:28:06Z")

</div>

Actually, think I might see the problem. On ARCHER2 your `.bash_profile` is loading a really old version of our um environment and thus picking up cylc 7 instead.

On ARCHER2 in `~/.bash_profile`

Change  
`. /work/y07/shared/umshared/bin/rose-um-env`  
to  
`. /work/y07/shared/umshared/bin/rose-um-env-puma2`

---

<div class="post-metadata">

**Author:** ![racheldiamond](https://avatars.discourse-cdn.com/v4/letter/r/eb9ed0/32.png) [@racheldiamond](https://cms-helpdesk.ncas.ac.uk/u/racheldiamond)\
**Post date:** [8 July 2026 13:11 UTC](https://cms-helpdesk.ncas.ac.uk/t/submit-failed-puma2-to-archer2/2121/5 "2026-07-08T13:11:43Z")

</div>

> [@RosalynHatcher](#):
>
> ~/.bash\_profile

Hi Ros,

Thanks, I just made this change in ~/.bash\_profile. However, when I log out of ARCHER2 and puma2 and log back in again, even though ~/.bash\_profile is changed as you said, on puma2 when I run cylc --version I still get 7.8.12.

Is there something else I need to do to make sure I’m loading CYLC 8? Do I need to delete the old .bash\_profile~ and .profile~ which are the only things I can find that still point to . /work/y07/shared/umshared/bin/rose-um-env ?

Rachel

---

<div class="post-metadata">

**Author:** ![RosalynHatcher](https://dub1.discourse-cdn.com/flex013/user_avatar/cms-helpdesk.ncas.ac.uk/rosalynhatcher/32/11_2.png) [@RosalynHatcher](https://cms-helpdesk.ncas.ac.uk/u/RosalynHatcher)\
**Post date:** [8 July 2026 13:44 UTC](https://cms-helpdesk.ncas.ac.uk/t/submit-failed-puma2-to-archer2/2121/6 "2026-07-08T13:44:59Z")

</div>

Hi Rachel,

You need to `export CYLC_VERSION=8` on PUMA2 either on the command line or in your `.profile`/`.bash_profile`. Sorry, I assumed you’d done this to have submitted the suite in the first place as it started to run with cylc8. 😀

Cheers,  
Ros

---

<div class="post-metadata">

**Author:** ![racheldiamond](https://avatars.discourse-cdn.com/v4/letter/r/eb9ed0/32.png) [@racheldiamond](https://cms-helpdesk.ncas.ac.uk/u/racheldiamond)\
**Post date:** [8 July 2026 13:56 UTC](https://cms-helpdesk.ncas.ac.uk/t/submit-failed-puma2-to-archer2/2121/7 "2026-07-08T13:56:34Z")

</div>

Perfect, I added ROSE\_VERSION=2 and CYLC\_VERSION=8 on my PUMA2 .profile and it seems to be running!! Thanks so much for the help 🙂

Best wishes,

Rachel

---

<div class="post-metadata">

**Author:** ![racheldiamond](https://avatars.discourse-cdn.com/v4/letter/r/eb9ed0/32.png) [@racheldiamond](https://cms-helpdesk.ncas.ac.uk/u/racheldiamond)\
**Post date:** [9 July 2026 15:56 UTC](https://cms-helpdesk.ncas.ac.uk/t/submit-failed-puma2-to-archer2/2121/8 "2026-07-09T15:56:33Z")

</div>

Hi Ros,

Unfortunately various tasks are failing to submit again – even though I do still have ROSE\_VERSION=2 and CYLC\_VERSION=8. Might the issue now be with ARCHER2? I’m attaching example error logs. Any ideas?

Thanks so much!

Rachel

 ![image](https://europe1.discourse-cdn.com/flex013/uploads/cms_support/original/1X/8625a48107bd0bb588947132adf11f0c4652e310.png)

![image](https://europe1.discourse-cdn.com/flex013/uploads/cms_support/original/1X/a4bee6db7d27010381ea40813da03a29a50643a7.png)

---

<div class="post-metadata">

**Author:** ![RosalynHatcher](https://dub1.discourse-cdn.com/flex013/user_avatar/cms-helpdesk.ncas.ac.uk/rosalynhatcher/32/11_2.png) [@RosalynHatcher](https://cms-helpdesk.ncas.ac.uk/u/RosalynHatcher)\
**Post date:** [10 July 2026 07:55 UTC](https://cms-helpdesk.ncas.ac.uk/t/submit-failed-puma2-to-archer2/2121/9 "2026-07-10T07:55:47Z")

</div>

HI Rachel,

Hopefully you subsequently, got the following alert from ARCHER2:

```auto
Dear ARCHER2 Users,

User access to ARCHER2 has temporarily been removed. This means that you will not be able to connect to the login nodes or access data. Running and queued jobs will continue to run. We will provide an update by 5pm tomorrow, Friday 10th July.

We apologise for the inconvenience caused.

```

Cheers,  
Ros

---

<div class="post-metadata">

**Author:** ![system](https://europe1.discourse-cdn.com/flex013/uploads/cms_support/original/1X/1fd2411499ffcbc299fe756cd5cdf26e44956558.png) [@system](https://cms-helpdesk.ncas.ac.uk/u/system)\
**Post date:** [12 July 2026 07:56 UTC](https://cms-helpdesk.ncas.ac.uk/t/submit-failed-puma2-to-archer2/2121/10 "2026-07-12T07:56:26Z")

</div>

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.
