Modifying pptransfer task?

Dear NCAS Helpdesk,

Is there a way to modify rose suites so only daily and monthly mean .pp files are transferred to JASMIN?

At the moment I am using u-ck766, a suite based on u-as037, which outputs a lot of 3-hourly and 6-hourly data (especially from UKCA), which I don’t need. I tried turning off the STASH for variables I didn’t need (by un-ticking the ‘include’ box for these variables), but the model failed in the coupled step with error:

Error code: 24
? Error from routine: UKCA_MAIN
? Error message: Some item addresses not found in D1 array
? Error from processor: 191
? Error number: 13

Is there a way to turn off output from UKCA in a way that doesn’t cause this error, or, failing that, make sure only daily and monthly variable files are transferred from ARCHER2 to JASMIN?


Best wishes,


Hi Rachel,

You should be able to turn off the UKCA STASH items in the “UKCA diagnostics” package, but you can’t turn off the “UKCA coupling Macro” ones as these are required for the coupling.

To select which streams are postprocessed/archived; in the panel ‘postproc → Atmosphere’’ switch process_all_streams to false and then specify which means file streams and fieldsfile streams you wish to process/keep.


Hi Ros,

Thanks so much, that’s really helpful. Are there any other packages required for the model to run?
Also, how can I tell which model output stream each variable will go to?

Best wishes,


Hi Rachel,

You’ll definitely need those with usage profile UPCOUP.

Each STASH request has a usage profile. Look at the usage profiles page and you’ll see each profile is associated with a file id. Look in the Model output stream panels to see the filename that each model stream is outputting to.