NaNs in error term in BiCGstab for high res domain

I’m running a nesting suite u-cm007 down to 200m resolution. Everything runs fine until the 200m nest, it fails at the first time step with the error.

???!!!???!!!???!!!???!!!???!!!       ERROR        ???!!!???!!!???!!!???!!!???!!!
?  Error code: 1
?  Error from routine: EG_BICGSTAB
?  Error message: NaNs in error term in BiCGstab after      1 iterations
?        This is a common point for the model to fail if it
?        has ingested or developed NaNs or infinities
?        elsewhere in the code.
?        See the following URL for more information:
?  Error from processor: 0
?  Error number: 41

I’ve re run with all the extra diagnostics and can’t see the source of the NaNs which I think tells me its an issue with my data I’m ingesting.

I’ve tried things like reducing the timestep and number of processors to no avail.

The ancillary generation was a bit weird as the VEGFRAC ancillary generation never worked so I set this to be generated via the recon routines as I think this will use 500m nest data. I noticed there was also grid warnings in the recon output for my aerosol ancillaries so investigated if that was the issue, it appears not as far as I’m aware.

I can seen anything obvious in my input data or the source of the NaNs so hoping CMS might offer some sage wisedom on the best next step to tack down the source of this error.