A license for Comp-FL is not available now

I am running an ISIMIP3a suite in JASMIN; everything works the first time, but I turned True l_inferno because I need to run the INFERNO model couplet to JULES. And then, with no more than a change, a rare error popped up. I am newer using JULES, so I must change something else. Does anyone have a clue?. My suite is u-dg698)

[FAIL] Error: A license for Comp-FL is not available now (-97,121).
[FAIL] A connection to the license server could not be made. You should
[FAIL] make sure that your license daemon process is running: both an
[FAIL] lmgrd process and an INTEL process should be running
[FAIL] if your license limits you to a specified number of licenses in use
[FAIL] at a time. Also, check to see if the wrong port@host or the wrong
[FAIL] license file is being used, or if the port or hostname in the license
[FAIL] file has changed.
[FAIL] License file(s) used were (in this order):
[FAIL] ** 1. 27004@sctlic3.esc.rl.ac.uk,27004@sctlic2.esc.rl.ac.uk,27004@sctlic1.esc.rl.ac.u

Hi Maria:
I looked at the suite u-dg698. And you say it worked on JASMIN the first time, so I presume that you’re already properly set in your rose-suite.conf file with LOCATION='jasmin' being the LOCATION.
I haven’t seen that error before. Are you running from the cylc1 Virtual Machine (VM)?
Can you try triggering the fcm-make again? Maybe it was just a one-off failure.

Hi Patrick,

I am running in cylc1.jasmin.ac.uk; yes, everything is set to run in JASMIN, and I ran it successfully before (literally, I copied it from one that just finished running yesterday). I have had the same error all weekend. I believe that might be because the current model ran using many resources since it had some parallelized tasks and took more than one week to finish. Still, I ran that today and made another copy to ensure I didn’t change anything else, and everything was the same error. So, I am sure it is not a time error, and that is related to that suite.

I asked to my University IT desk and they said: “If you run ifort, it shows which license servers it’s trying to use. They’ve got a triple redundant server, and only one answers. You need at least two for it to function”

Again I should highlight that my work is running some parallel work.

Hi Maria Paula
To run ifort on cylc1, one needs to type these commands (the modules are listed in

module load intel/19.0.0
module load eb/OpenMPI/intel/3.1.1

When I do this, I get the same error message that you did.

I also tried to use updated modules (as listed in the JULES FLUXNET suite ~/roses/u-al752/site/suite.rc.CEDA_JASMIN):

module load intel/20.0.0
module load contrib/gnu/gcc/7.3.0
module load eb/OpenMPI/intel/4.1.5

But I get the same error messages then.

Probably if you went back to running it with l_inferno=False, you would get the same error now.
I will ask the JASMIN Helpdesk about this. Maybe one of their servers is down.
Patrick McGuire

:open_mouth: It did failled when I tuner False l_inferno!, but I ran other not related JULES model and seemed to be OK.

Thank Patrick, any information is much apreciated.

Hi Maria Paula:
This is the response I got from the JASMIN Helpdesk:
“Thank you for the report about the Intel compiler licences. We have raised the issue with our systems team, and one of us will let you know when it is fixed.”

I just tried to run ifort again on cylc1, and I still get the same error as you did.

Hi Patrick!
Thank you and the JASMIN helpdesk for the help. It is good to know that this error is not directly related to my suite. I just checked, and it is not sorted yet, but I hope tomorrow.

Best wishes,
Maria Paula

Hi Maria Paula:
This is the news I got just now from the JASMIN Helpdesk:
“This is to let you know that the Intel compiler licences are now working again.”

I also just tried to run the ifort compiler on cylc1, and it doesn’t complain about licenses anymore.

1 Like

Amazing! :tada: my suite is advancing now.
Thank you very much for keeping me posted until the end.