Failed to complete test.platform.c8

I am trying to follow the advice on test.platforms.c8. I have confirmed the puma2 setup works:
$ rose host-select archer2
I did set CYLC_VERSION=8
However the archer2_bg task failed. Of course the localhost_bg worked. and the third task (jasmin sci8?) did not start. [I have never tried to jasmin from archer2]

~mricha/cylc-run should be readable.

any suggestions welcome. I hope it is a straightforward solution.



Did it fail repeatedly?


Can you log into ln01,ln02,ln04 and from puma2 without being asked for any information (password etc.)?

I think so. “submit failed”.

what is a cylc 8 command to reset and start a task in tui? (Sorry am at UKMO meeting so intermittent comms).

Hi Jeff,
well I thought it would be unlikely as it is quite a palaver just to login from a standard university system. I can confirm ssh does not work from ln02.

I always have to go to and use 2FA and use my jasmin user-id (not same as any of my archer2 ids.) I did try ssh -l jasmin_id as well.

I am not particular worried about jasmin as I have not read any doc guidance on doing that. it just happens tobe part of Annettes test suite.

I wonder why the archer2_bg did not work when I have proved for myself that I can run a standard UM 13.2 suite okay.
Does it need CYLC_VERSION=8 on the lnXX node?


Hi Mark

The error seems to be coming from this file /home/n02/n02/mricha/cylc-run/test.platforms.c8/run1/log/scheduler/01-start-01.log

2024-06-19T19:10:41+01:00 ERROR - platform: ln01_bg - initialisation did not complete
        ssh -oBatchMode=yes -oConnectTimeout=8 \
            -oStrictHostKeyChecking=no ln01 env CYLC_VERSION=8.2.5 \
            CYLC_ENV_NAME=cylc-8.2.5-1 bash --login -c \
            'exec "$0" "$@"' cylc remote-init archer2 \
            $HOME/cylc-run/test.platforms.c8/run1 \
        Usage: cylc [task] remote-init [--indirect-comm=ssh] UUID RUND
        (This command is for internal use.)
        Install suite service files on a task remote (i.e. a [owner@]host):
            .service/contact: All task -> suite communication methods.
            .service/passphrase: Direct task -> suite HTTP(S) communication only.
            .service/ssl.cert: Direct task -> suite HTTPS communication only.
        Content of items to install from a tar file read from STDIN.
                On success or if initialisation not required:
                - Print SuiteSrvFilesManager.REMOTE_INIT_NOT_REQUIRED if initialisation
                  not required (e.g. remote has shared file system with suite host).
                - Print SuiteSrvFilesManager.REMOTE_INIT_DONE on success.
                On failure.
           UUID               UUID of current suite server process
           RUND               The run directory of the suite
        cylc-remote-init: error: Wrong number of arguments (too many)

I’m not sure why you get this error, someone with more cylc8 knowledge will have to look at it.


1 Like

Hello Jeff and Grenville,
I just had some great local support. It seems I missed a step in the PUMA2 setup because I already have .bash_profile. I should have looked closer - I now have
. /work/y07/shared/umshared/bin/rose-um-env-puma2
on archer login account.

basic error on my part, sorry. Thanks for looking.