Jasmin related command line fail

I’ve copied u-cn134 to u-cz079

on running I get command line error related to Jasmin -
I 'm not trying to transfer to Jasmin so I turned off PP transfer but still get the same error.

many thanks

[INFO] install: bin

[INFO] source: /home/jgrist/roses/u-cz079/bin

[INFO] install: ana

[INFO] source: /home/jgrist/roses/u-cz079/ana

[INFO] delete: suite.rc

[INFO] install: suite.rc

[INFO] REGISTERED u-cz079 → /home/jgrist/cylc-run/u-cz079

[FAIL] ssh -oBatchMode=yes -n sci2.jasmin.ac.uk env\ ROSE_VERSION=2019.01.3\ CYLC_VERSION=7.8.12\ bash\ -l\ -c\ '"$0"\ "$@"'\ rose\ suite-run\ -vv\ -n\ u-cz079\ –run=run\ –remote=uuid=45c9a488-bbf7-4d47-95b8-e539ad15e6a4,now-str=20230815T155816Z # return-code=255, stderr=

[FAIL] ssh: connect to host sci2.jasmin.ac.uk port 22: Connection timed out

Hi Jeremy,

Sorry the CANARI suite has a load of extra tasks, which you won’t need - a couple of which run on JASMIN. Unfortunately, they weren’t put on switches to enable them to be turned off easily.

However, I’ve just modified u-cn134 this morning to make it possible to switch them off.

Please re-copy u-cn134 and then in the panel suite conf → Build and Run switch off the following tasks:

  • Create frames files
  • Modify NetCDF Metadata
  • Storm Identification
  • Run monitoring scripts
  • Migrate to JASMIN Elastic Tape
  • PPTransfer

Hopefully that will fix the attempt to contact JASMIN. I’m unable to test it without messing up my running jobs.


Hi Ros,

Thanks for doing this:

¡¤ I could not locate the switch for ¡®Migrate to JASMIN Elastic Tape¡¯

¡¤ I tried to run it with the other switches off and it failed at fcm_make2_um:


[FAIL] Reading from filehandle failed at /mnt/lustre/a2fs-work1/work/y07/shared//

umshared/software/fcm-2019.09.0/bin/…/lib/FCM/Util.pm line 257.

[FAIL] compile+ 1.9 ! ATM_STEP_4A_MOD.mod ← um/src/control/top_level/atm_stee


[FAIL] ! ATM_STEP_4A_MOD.mod : update task failed

[FAIL] ! u_model_4a_mod.o : depends on failed target: ATM_STEP_4A_MOD.mod

[FAIL] fcm make -C /work/n02/n02/jgrist02/cylc-run/u-cz093/share/fcm_make_um -n

2 -j 6 # return-code=2

2023-08-16T10:57:50Z CRITICAL - failed/EXIT

The “Migrate to JASMIN Elastic Tape” is dependent on PPTransfer so if you turned that off first the other will have disappeared - that’s fine.

This is the same error that you had in: Cancelled due to timelimit. Just retrigger the fcm_make2_um task.