JULES gives "CPU time limit exceed" error on JASMIN

Hi CMS Helpdesk,

A ‘CPU time limit exceeded’ error started to occur during fcm_make since Tuesday when I try to compile the model. It was indeed compiling successfully that morning but somehow started to fail afterward although I did not change anything in the model or Rose suite settings.

fcm_make gives the following error after it runs for 10 min.

 CPU time limit exceeded
 2022-10-28T09:49:11+01:00 CRITICAL - failed/XCPU

The directory to my Rose suite: /home/users/gorguner/roses/u-ck476

Could you please advise on how to fix this error?

Thanks,
Merve

Hi Merve
Maybe you can increase the time limit fro 10 mins to 20 or 30 mins?
Does that help?
Patrick

Thanks, Patrick. I changed the time limit to 20 min and the model compiled successfully. :blush:

I thought the problem was something else because the error started to occur for no reason. The default setting of 10 min was enough to compile the model up until Tuesday.

Hi Merve:
I’m glad it’s working. It’s hard to say why it took longer. If it continues to take longer for more than a week or two, then maybe we should look into it.
Patrick