Request UM startdump transfer from Monsoon to Archer2


I’m trying to port the suite u-cx011 from Monsoon to Archer2. I can compile the suite OK but recon fails with the error “wrong no of atmos prognostic fields” (error code 102). I’ve tried a few different start dumps from the Archer2 umshared/standard_jobs directory (e.g. “standard_jobs/inputs/vn12.0/N48L70_EG/n48_eg_start_dump”), however all of them seem to give the same error.

The README file for the Archer2 umshared directory states that the directory is a partial copy of the /projects/um1/standard_jobs directory on MONSooN. Would it be possible to request the transfer of another standard job startdump? Specifically, the suite I’m copying uses “/projects/um1/standard_jobs/inputs/vn12.0/IDL/n48_eg_aquaplanet.start”.

If that isn’t possible, would you be able to help me diagnose which fields are missing from the startdumps I’m trying to use?

Many thanks,

It should be in /work/y07/shared/umshared/standard_jobs/inputs/vn12.0/IDL

hope that works for you

Thanks for copying that across! I can access the file OK, but oddly I’m still getting the “Wrong no of atmos prognostic fields” error. Looking at the start dump contents vs. the model stash requests, the model setup requests quite a few prognostics that aren’t in the start dump, for instance pressure on both theta and rho levels. Can you help me understand what’s going on here? Is there another place the model looks for initial fields besides the file given as “astart” in namelist:nlcfiles?

This seems to also be true of other suites using the idealised UM, for instance u-bn269 which has pressure on rho levels, pressure on theta levels, and surface pressure as prognostics, but uses the start dump standard_jobs/inputs/vn10.9/N48L70_EG/n512_recon_input_dump, which contains none of those three variables. None are given via ancillary files, and “Transfer data” is set to false. It feels like I must be missing something obvious?

pl tell us the suite id

Hi Grenville, thanks for replying. My copy of u-cx011 is u-cz956; I have committed the current version. The UM compiles OK on Archer2, but recon fails with the following error:

???!!!???!!!???!!!???!!!???!!! ERROR ???!!!???!!!???!!!???!!!???!!!
? Error code: 102
? Error from routine: INITIAL_4A
? Error message: INITDUMP: Wrong no of atmos prognostic fields
? Error from processor: 0
? Error number: 79

Please let me know any other information you require.

Hi Dan

It’s not running the reconfiguration - the error comes from the model ( the job.err file also says it’s running um-atmos.exe). Please take a look at my modified copy of u-cz956 in my roses directory on pumanew to see how to fix the cylc. A couple of changes in suite.rc are needed. The reconfig failed with

Error opening Vertical Levels namelist file:/home/d04/appc/um_nml/vertlevs_L100_6km.nml

which I have not pursued.


Hi Grenville,

Thanks very much for sorting this out for me!