UKESM1 -- be303

Hi I have copied suite u-be303 so that I can change diagnostics and run it for a short period. But when I run the stash validate macro I get a bunch of errors about unavailable STASH diagnostics. Some of these make sense. I only have an atmosphere so sea-ice diagnostics won’t be doing much; though why are they in the configuration? More concerning is that I am getting complaints about the S cycle which I think is turned on.
My job is u-cn956.

And I am also getting a bunch of errors from section 19 “invalid version mask”.

I am trying to turn off diagnostic 00250 (CO2 ocean flux) which is unavailable (according to STASHTstmskValidate) but get an error when I try to do so. Error is “Warning – cannot override this setting:…”

And some more questions – I have made recommended adjustments for job to run on archer2 –
See UKESM1-AMIP Release Notes
The job will need access to /work/y07/y07/umshared/ukesm/restarts
When I try and list this directory on archer2 I get a “permission denied” error.


And when I ran the suite I got an error: …
[WARN] archer: (ssh failed)
[FAIL]: No hosts selected.

Hi Simon,

We have ported u-be303 to ARCHER2 in the archer2 branch of this suite as we don’t have write access to the trunk. We are waiting for it to be merged to trunk. Please rosie copy u-be303/archer2 to get the working ARCHER2 version of this suite.


Hi Ros,
thanks. I will do that!

Done. My job is u-cp254. Made changes I wanted. I’ve turned off almost all diagnostics and added 8 more with the output going to Netcdf output. But when I run the validation I get a bunch of errors:

1 error from ItemsTstmskValidate - invalid stash request which looks to be dues to asking for CO2 ocean flux. Seems odd to be asking for that in a AMIP simulation.

A lot of warnings about domains not being used. I assume I can ignore those.

8 errors from TidyStashValidate complaining about identical sections which seem to be stash domains & time processing options that I am not using. Can I ignore these errors or should I remove the offending ones… I’d rather not remove them in case I need to turn sone diagnostics back on –



You can ignore all these messages


Hi Grenville,
thanks. Submitted (after sorting out project code access). I am getting an error message from fcm_make_um.
error messages suggest some problem with subversion with final message being “No more creditentials or we tried too many times”. Trying to access a branch of simonwilson’s.
Does my cached MO password run out after a while??


I think it was some time out on the subversion password. I logged out & back in again. Submitted and seems to be working now!

I am now running! I have switched off all diagnostics except UKCA_coupling (they seem to be needed to make the model run) and have a small number of diagnostics going to netcdf. But the netcdf files only contain longitude_t_bounds & latitude_t_bounds. I am also getting a bunch of other files output. The other files look like “normal” UM output and appear to come from several different streams.

What am I doing wrong?


The output to upm_nc is monthly, but the nc0 stream is reinitializing daily – I’m not sure if that is the problem, but I’d fix that first.

The UKCA coupling fields are necessary.
You can stop the creation of empty fields files by disabling their usage profiles.


Hi Grenville,
thanks – will sort out netcdf. How do I disable usage profiles? I don’t want to delete them in case I want to turn them back on again. I looked at this question: Modifying pptransfer task? - #4 by RosalynHatcher but I don’t see how to activate the nc0 stream in the panel… nc0 gives me a red warning…

I also had another error: Cannot use legacy naming with hours = 3600,must be < 3600.
How do I turn legacy naming off?



Hi SImon

I should have said disable output streams:
In the rose Model Input and Output → Model output streams, right click on pp116 (say) select Ignore section… and hit OK. (Enable an ignored section the same way.)

legacy naming:
the nc0 stream has

prob better to use

(right click on Model Input and Output and selecr Help to see an explanation of file naming_

I don’t understand your references to activating the nc0 stream.