UKESM1 failing to restart


I’m trying to restart a few UKESM runs (e.g. u-cb380, u-cd124) on NEXCS, which I think
stopped due to maintenance, but they are failing on the coupled task:

[SUBPROCESS ERROR] <module ‘error’ from ‘/working/d03/lamar/cylc-
Traceback (most recent call last):
File “./link_drivers”, line 205, in
envinsts, launchcmds = _run_drivers(common_envars, mode)
File “./link_drivers”, line 69, in _run_drivers
File “/working/d03/lamar/cylc-
run/u-cd124/work/17940701T0000Z/coupled/”, line 699, in
exe_envar = _setup_executable(common_envar)
File “/working/d03/lamar/cylc-
run/u-cd124/work/17940701T0000Z/coupled/”, line 359, in
nemo_first_step = int(re.findall(r’.+=(.+),’, first_step_val)[0])
IndexError: list index out of range
[FAIL] run_model # return-code=1
2021-05-07T13:41:30Z CRITICAL - failed/EXIT

Following #3385 I tried deleting the last directory under /work and
restarting but no success.

Any help much appreciated,
Thank you,

Hi Lauren,

I’ve found this error listed on one of the Met Office’s known errors webpages:

Index out of range in nemo driver

It looks like the namelist_cfg file is indeed missing from the previous cycle’s work directory. Could you try copying it back into place as per the instructions and see if that fixes the problem.


Hi Ros,

Sorry for missing that! Yes, that’s fixed it. Thanks very much.


5 posts were split to a new topic: Postproc_cice missing file for seasonal mean