Unknown modules

Getting the following error message

Lmod has detected the following error: The following module(s) are unknown:

Please check the spelling or version number. Also try “module spider …”
It is also possible your cdcache file is out-of-date; it may help to try:
$ module --ignore_cache load

Also make sure that all modulefiles written in TCL start with the string

However, none on the commands in the error message work
“module spider …” or module --ignore_cache load

module load does not list any modules in the directory /apps/jasmin/supported/modulefiles.temp_workaround/

Unsure how to solve this.

Hi Noel:
are you getting that error message when running a JULES suite? Which suite is it? Does it happen for other JULES suites?

Hi Patrick,

This problem doesn’t occur for other JULES suites on JASMIN. However, for u-cx096, it happens straight away during the fcm_make stage.
u-cx096 is a copy of u-cm847 on JASMIN (Garry Hayman):
• JULES with JULES Crop switched off
• JULES Crop (vn6.3 trunk), with optimised parameters
• JULES Crop DVI (vn6.3 branch above), with optimised parameters and critical value of DVI for
The module intel19.0.0.117/4.7.4 is available in the following directory:
(base) [nmc@cylc1 intel19.0.0.117]$ ls
4.7.4 4.7.4~ fortran

However, when I run the command “module avail”, it does not appear.

Hi Noel:
In your file:
~nmc/roses/u-cx096/rose-suite.conf ,
you have these lines of code:

NETCDF_MODULES='/apps/jasmin/supported/modulefiles.temp_workaround/netcdf/intel19.0.0.117/4.7.4 /apps/jasmin/supported/modulefiles.temp_workaround/netcdf/intel19.0.0.117/fortran/4.5.3'

These look to be non-standard. Who provided them for you? Why do you need these non-standard versions? Maybe you can use such NETCDF modules as in other JULES suites (i.e. u-al752)?

I get the same error when I use the standard netCDF versions in u-al752:

Lmod has detected the following error: The following module(s) are unknown:

The reason I used the non-standard versions as they are the versions in suite u-cm847.

Hi Noel:
Did you see the email about this? Does that help?

I did, I’ve tried it but I’m still getting the same error

Hi both,

Just to share the email that I sent about this. Garry’s suite is based on one of mine, which uses these netCDF libraries that were installed by the Jasmin team several years ago. Recently the way of invoking them changed. You need to let the module command know where they are before you load them:

module use /apps/jasmin/supported/modulefiles.temp_workaround
module load netcdf/intel19.0.0.117/4.7.4 netcdf/intel19.0.0.117/fortran/4.5.3

In the suite.rc, this would look like:

                     module use {{ MODULE_PATH }}
                     module load {{ NETCDF_MODULES }}

Where MODULE_PATH and NETCDF_MODULES are set in rose-suite.conf:

NETCDF_MODULES='netcdf/intel19.0.0.117/4.7.4 netcdf/intel19.0.0.117/fortran/4.5.3'

This is currently working for me (eg in u-cv329 if you want to compare). Otherwise, there is no particular need to use these libraries over the ones in the jules GWS (which are better supported), so you could pursue using those instead.


The suite completes the fcm_make stage now but returns
{MPI Task 1} [FATAL ERROR] file_ts_open: Given file ‘/gws/nopw/j04/hydro_jules/users/matwig/data/met_daily/chess_rsds_201801.nc’ does not exist
I cannot look inside the directory ‘/gws/nopw/j04/hydro_jules/users’ ‘Permission denied’
How can I get permission to access the folders in these directories?

Hi Noel,

Sorry about that - I will make sure these files are moved to the public area of the Hydro-JULES GWS (they will be available in /gws/nopw/j04/hydro_jules/data/uk/driving_data/chess/chess-met/daily/ alongside the 1961-2017 files)


Hi Emma & Noel:
Thanks Emma for the help here!
Noel: Does it work now?

I will try again when the files are copied to:

Hi Noel,

The 2018-19 files are now in /gws/nopw/j04/hydro_jules/data/uk/driving_data/chess/chess-met/daily/ and have been renamed to match the 1961-2017 files. You’ll need to update the 2018-19 lines in app/jules/file/chess-met_flist.txt to point to the correct files.


The suite fails at the vector_to_grid stage and gives the following error
Is there a way to load the netCDF4 module and reload and re-run through the last stage?

Traceback (most recent call last):
File “/home/users/nmc/cylc-run/u-cx096/app/vector_to_grid/bin/vector_to_grid.py”, line 3, in
import netCDF4 as nc
ImportError: No module named netCDF4
[FAIL] vector_to_grid.py $GRID_LOC $OUT_LOC/${ROSE_SUITE_NAME}_jules*.*.nc <<‘STDIN
[FAIL] ‘STDIN’ # return-code=1
2023-05-25T09:10:06Z CRITICAL - failed/EXIT

Hi Noel:
I tried to copy your suite, and then retrigger your vector_to_grid app in the cylc GUI.
It seems to work fine, and it finds the netCDF4 module in Python. What happens when you retrigger the vector_to_grid in the cylc GUI?

Hi Patrick,

The following command just corrected it

conda install -c conda-forge netcdf4

Hi Noel:
It’s great to hear that you got it working!
Nice job!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.