"Can't exec xxdiff" error

Hi CMS Helpdesk,

I upgraded my JULES branch to the next model version. During merging, many text conflicts were listed. When I use the ‘fcm conflicts’ command to pop up the 3-way xxdiff display, I get the error below. Am I using this command in the wrong way?

-bash-4.2$ pwd
-bash-4.2$ fcm conflicts
[info] src/control/shared/fluxes.F90: in text conflict.
[FAIL] fcm_graphic_merge src/control/shared/fluxes.F90 /home/users/gorguner/vn6.2_wtrac_branch/src/control/shared/fluxes.F90.working /home/users/gorguner/vn6.2_wtrac_branch/src/control/shared/fluxes.F90.merge-left.r20512 /home/users/gorguner/vn6.2_wtrac_branch/src/control/shared/fluxes.F90.merge-right.r24202 # rc=2
[FAIL] Can't exec "xxdiff": No such file or directory at /apps/jasmin/metomi/fcm-2019.09.0/bin/fcm_graphic_merge line 66.


Hi Merve,

That is indeed the correct usage.

I’ve just tried running that command and get the same error message as you. It looks like xxdiff which is used to show the conflicts is not available…

rshatcher@cylc1$ xxdiff
-bash: xxdiff: command not found
rshatcher@cylc1$ which xxdiff
/usr/bin/which: no xxdiff in (/apps/jasmin/metomi/bin:/usr/lib64/qt-3.3/bin:/usr/local/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/opt/puppetlabs/bin:/home/users/rshatcher/bin)

The installations of Rose/Cylc/FCM are maintained by the JASMIN team. Please contact the JASMIN helpdesk.


1 Like

Ros, thank you very much for checking. I will contact the JASMIN helpdesk.