Dump does not match STASH list


My suiteid is u-cv482. I have been trying to edit my own stash list through the rose gui and for now I have many stash requests that are commented out (requests that I have not ticked the ‘Incl?’ option) because I want to make sure one works as I expect first. Anyway I have a stash request for W wind component (item 150) which works and I’ve now checked u wind to be in the stash requests. When I do this however I’m getting an error: ‘UM_READDUMP Dump does not match STASH list’. When I go into the pe_output it seems that it was expecting to read the W-wind but found the u-wind item code. I’ve done all the macros and made sure to reload the suite before retrying the run but this is not fixing the error. I’m out of ideas as to why it expects to read W-wind instead of u-wind.

Thank you for your help


It looks like you have fixed this problem?


I’d be very keen to hear what your solution was @rglazer because I’ve been having this issue too (with QCF/QCL/qT on theta levels )

[0] ???
[0] ???!!!???!!!???!!!???!!!???!!! ERROR ???!!!???!!!???!!!???!!!???!!!
[0] ? Error code: 6
[0] ? Error from routine: UM_READDUMP
[0] ? Error message: UM_READDUMP Dump does not match STASH list: Wrong processing code.
[0] ? Error from processor: 24
[0] ? Error number: 74
[0] ???

Feels similar to this issue but this time it’s not about the tidystash macro…

Hi shakka I also was reading your issue on this.

So I don’t understand how or why but restarting the suite (or restarting a run) seems to solve these issues. I haven’t had this issue since last week. I’m only guessing here because I don’t understand in depth how the rose suite works but is the UM readdump initialised only when the suite is started? Basically if you add a new stash request while you have a run going and just reload the suite it will not update the readdump - it only updates the namelists?

I have just had a run going where I changed the stash by checking or unchecking variables in the stash list and then reloading the suite and the runs were outputting correctly so I’m now unsure what the source of the problem was.

Ahhh, darn. That’s not gonna work for me. I get the same problem even when I’m reloading mid-way. I’m now testing the behaviour in another suite, but I’m not holding out much hope… @grenville any further thoughts on why the processing code is causing problems?

Have you tried restarting the suite entirely? As in stop the run and then do a ‘rose suite-run --restart’ and go from where you left off?

I have indeed. And I’m seeing the same error in my other suite too. Seems peculiar…

I’m not clear on the sequence of events that led to the UM_READDUMP error, but changing a STASH configuration mid run can cause problems - the dump is used as a place to store diagnostics that need to be remembered over cycles and needs to have space reserved to such data. Adding STASH mid run may require the start file to be reconfigured.


1 Like