Email verification step not working within UM Trac on

Dear NCAS-CMS helpdesk,

I’m having trouble accessing the UM Trac system on

I can log in OK, but then it displays a warning message:

Warning: Your permissions have been limited until you verify your email address.

I though, OK – no problem, this is just that I need to verify my email address.

So I proceeded then to click “verify your email address”.

And it then seemed to be OK, in progressing to the “Verify Email” page, saying that an email had been sent to my email address with the “verification token”, that I realise I then simply need to type in, to then have my email address verified.

However – this is not working because I then do not receive any email with the verification token.

Initially I thought maybe this is getting caught in a spam filter with my Univ. Leeds email address, but the same thing happened when I tried changing my email address instead to

It says that an email has been sent with a token to verify my email address.

But then I don’t receive any email with the token info.

Please can someone in the team try this verification step – as it doesn’t seem to be work (either with my University email address or with my gmail address).

Looks like it is simply a case of the email not being sent.

Thanks for your help with this.

Best regards,


** Dr. Graham Mann, Lecturer in Atmospheric Science **
** Institute for Climate & Atmospheric Science T: +44 0113 3431660 **
** Room 10.108, School of Earth & Environment F: +44 0113 3435259 **
** University of Leeds, Leeds, LS2 9JT, U.K. E: **

** Apologies if this email took longer to reply to than you expected **
** I am currently participating in the UCU “work to contract” action **
** for fair pay settlement, more secure HE employment practices & to **
** oppose the proposed cuts to the USS occupational pension scheme. **

** **

Password reset and sent by email.

Hi Ros,

Thanks a lot for this – that’s great.

Yes that worked fine to login to UM Trac on PUMAtest with temporary password you set.
(worked OK from Firefox browser, but didn’t work from Safari for some reason).

See I’ve uploaded below a screen-shot PNG showing I can now access the v8.4 branches on PUMA.

Thanks for sorting that out so quickly for me – much appreciated.