Fcm_ not working make_plots fail

  1. fcm_make taking forever and fail. error messages
    ~gwy1998/cylc-run/u-al752/log.20230201T144139Z/job/1/fcm_make/01/job.err says:
    /home/users/gwy1998/cylc-run/u-al752/share/fcm_make/fcm-make.lock: lock

  2. make_plots fail ValueError: no field of name GPP

Hi Wenyao:

GPP doesn’t work yet in u-al752 for the NEON sites.

So probably the easiest thing to do is run it without the NEON or LBA sites.

To do this, you might try:

  1. changing SUBSET from ‘all’ to ‘peg’ in the rose-suite.conf file. This will only run the FLUXNET sites and it will skip the NEON and LBA sites.
  2. do a rose suite-run --reload
  3. in the cylc GUI, retrigger the make_plots app by right-clicking on the make_plots app and then select the trigger option. You don’t need to rerun all the jules apps.


Hi again, Wenyao

yes, your error log file ~gwy1998/cylc-run/u-al752/log.20230201T144139Z/job/1/fcm_make/01/job.err said last week:

/home/users/gwy1998/cylc-run/u-al752/share/fcm_make/fcm-make.lock: lock exists at the destination

So maybe you can remove the directory /home/users/gwy1998/cylc-run/u-al752/share/fcm_make

and then trigger the fcm_make app again in your rose/cylc suite?

Are you still having that problem this week?

During the extended JASMIN maintenance last week, I tried to list your directory /home/users/gwy1998/cylc-run/u-al752/share/fcm_make

and that seemed to freeze my terminal. I think your cylc-run directory is mounted on the scratch-pw2 disk, which might still have been under maintenance. But the maintenance should be over now.


Dear Pratick,

Thanks for replying. The problems have been solved now.

Hi Wenyao:
That’s great to hear! I am glad it’s working now.