Pumatest - ARCHER2 connection and UKCA test job

Dear CMS,

I am trying to submit a UKCA job on ARCHER2, but am unable to submit it using ‘pumatest’. I am able to login on pumatest and ARCHER2. I think the connection between ‘pumatest’ and ‘ARCHER2’ has not been approved (or ssh key problem). I am getting the following message when I trying to ssh ARCHER2 from pumatest:

-bash-4.1$ ssh login.archer2.ac.uk

Warning: the RSA host key for ‘login.archer2.ac.uk’ differs from the key for the IP address ‘’
Offending key for IP in /home/akpandeyjnu/.ssh/known_hosts:5
Matching host key in /home/akpandeyjnu/.ssh/known_hosts:12
Are you sure you want to continue connecting (yes/no)? yes
PTY allocation request failed on channel 0
Comand rejected by policy. Not in authorised list
Connection to login.archer2.ac.uk closed.

I have followed the instructions available on 1. Getting set up — NCAS Unified Model Introduction (ncas-cms.github.io) and waiting for more than 48 working hours as instructed on the page. Am I missing something?

Can you please also suggest to me a UKCA job for ARCHER2 for a test run?

Regards, Alok

Hi Alok,

Your archerum key was added by ARCHER2 on Monday. You need to fix the “Offending key” message for things to work properly. Remove the offending keys (in the message above that’s line 5) from your ~/.ssh/known_hosts file. Try the ssh command again to check you then the get expected response with no prompt for any input (including yes/no). You may have multiple offending keys to remove.


Hi Ros,

Thanks for pointing me to the offending key error.

I have tried to submit a test job on archer2 ‘u-cq277’, but got the following error:

[FAIL] cylc validate -o /tmp/tmp9ZfOvi --strict u-cq277 # return-code=1, stderr=
[FAIL] ERROR, undefined parent for atmos_lrun: ATMOS_TEST_RESOURCE

How to fix this error?

I have taken a copy of u-be303 and followed the instructions available on UKESM1-AMIP Release Notes (ncas.ac.uk) to set it for ARCHER2.

Am I using the suitable suite to run on ARCHER2 or do I use something else? Can you please point me to the right suite for the UKCA job for ARCHER2?

Regards, Alok

Hi Alok,

You need to take a copy of the ARCHER2 branch for the suite:

rosie copy u-be303/archer2

u-be303 is the UKESM1 AMIP suite, this includes UKCA. Whether it’s the right suite for you I can’t say, as I don’t know what work you are doing. There are many different suites that run UKCA.


Hi Ros,

Thanks for this. I am working on NERC LSO3 Project (why is Lower Stratospheric Ozone (O3) not recovering?) and have to run UKCA and carry forward Iodine development work by Ewa (She has done all development on MONSOON and a rose suite of her job is u-cn823), but I want to do iodine development on ARCHER2.

To start with ARCHER2, I was just looking for a job to submit from pumatest to ARCHER2 and get the page Porting (ncas.ac.uk). I think the connection between pumatest and ARCHER2 is working now (although the job has not been submitted on ARCHER2 yet).

I am getting the following error message:
sbatch: error: Batch job submission failed: Invalid account or account/partition combination specified

Which I think is related to the project account. I have changed the project account (n02-cms à n02-LSO3), but still getting the same message.

Is the ‘LSO3’ project account not working for me? Or is it due to a problem somewhere else?

Regards, Alok

PS: I am not sure if this should be a new ticket or not. Happy to open a new ticket if required.


There is no budget n02-LSO3. Please check with your PI.


Hi Grenville,

The budget for the project is ‘n02-NEV011863’. I modified the Account code to ‘n02-NEV011863’ but still got the same error.

I think someone (perhaps you!) needs to configure it so that I can use this budget. I can send a separate email if required.

Regards, Alok


You are added to n02-NEV011863