Required field is not in input dump (ERA5 driven RNS)

Apologies if this is a trivial question but I am having some trouble understanding errors to do with the input dump in the RNS.

I am trying to run suite u-dc256, which is a version of the RNS on ARCHER2, driven by ERA5 boundary conditions. It’s set up to use two different configs - GA7 and RA3, just for interest really - at 12km resolution with a convection parameterisation, but it seems to be having some errors with the input dump that I don’t understand.

When I try to run the GA7 config, the suite has an error in the recon step:

??????????????????????????????????????????????????????????????????????????????????????
???!!!???!!!???!!!???!!!???!!!       ERROR        ???!!!???!!!???!!!???!!!???!!!???!!!
?  Error code: 30
?  Error from routine: RCF_RESET_DATA_SOURCE
?  Error message: Section   0 Item   274 : Required field is not in input dump!
?  Error from processor: 1
?  Error number: 3
??????????????????????????????????????????????????????????????????????????????????????

Similarly, trying to use RAL3 I get an error in the forecast step

????????????????????????????????????????????????????????????????????????????????
???!!!???!!!???!!!???!!!???!!!       ERROR        ???!!!???!!!???!!!???!!!???!!!
?  Error code: 102
?  Error from routine: INITIAL_4A
?  Error message: INITDUMP: Wrong no of atmos prognostic fields
?  Error from processor: 218
?  Error number: 22
????????????????????????????????????????????????????????????????????????????????

So I think there’s something wrong with the input dump, which manages to get turned into an astart file in recon with RAL3 but not with GA7. The GA7 error implies that it’s specifically to do with the topographic index. However I thought the suite I was using to generate ancils was generating a topographic index? I had used the ancils_12km branch of suite u-da256 to generate the ancils and it has a topographic index step which references Doug Lowe’s topographic index file in the ANTS top app… so I kind of assumed that would be fine?

Also, I have seen the thread here and have tried swapping i_rad_topographic from 4 to 0, and I don’t have any stash requesting orographic gradients as far as I can tell, but the same error is produced regardless.

I made this suite by cloning suite u-db900 which runs fine (other than archiving at the moment but that’s a separate and unrelated problem) - but is 2.2km resolution and does not use a convection parameterisation. Other than that they’re exactly the same, as far as I can tell, and their ancils were generated in the same way (using suite u-da256 again).

Does anyone have any insight on why this is failing and if there’s anything I can do to make it work? Or have I missed something? Thanks in advance!