Retaining all pe output by avoiding housekeeping


I am attempting to debug a problem with an ancillary which is not interpretted correctly on ARCHER2, but worked as intended on ARCHER.

The ancillary is a mask of indicies that are used to categorise regions in 2D and scale anthropogenic emissions. I want to confirmt he values of the ancillary used by the model at each gridpoint and have included debug write statements for this purpose in the ukca_add_emiss.F90 routine in my branch vn11.1_AEROCOM_MMPPEs.

Unfortunately, only output from the first MPI task is retained in pe_output/ce487.fort6.pe000 and the corresponding lat/lon pairs share the same index in my ancillary. I attempted to suppress the effect of housekeeping by toggling the ‘prune-work-at’ cog in my suite and setting to ‘User Ignore’, but this didn’t work as I imagined.

Could you please advise me how I can view output from other MPI tasks?



Hi Leighton,

Switch ATMOS_KEEP_MPP_OUTPUT in “um → env → Runtime Controls → Atmos only” to true.


1 Like

Hi Ros,

Thanks for the advice. I set ATMOS_KEEP_MPP_OUTPUT to true, but so far as I can see I still only have access to output from the first MPI task.

I’m viewing the output here on ARCHER2:

and here on pumatest:

Am I looking in the right places?




set prnt_writers to 1