Submitting a job to ARCHER2


I’m trying to submit a bit outdated UM v8.4 job from UMUI on pumanew to ARCHER2. I’m currently trying to run my copy (tfkqy) of gmann’s xplpg, which Graham is trying to run himself.

However, the problem I currently have is different from his. The last few lines of

Start: 2022-12-07 12:39:21=> ssh -n -oBatchMode=yes mkdir -p /work/n02/n02/myosh/um/tfkqy/baserepos/UMATMOS/cfg
Permission denied (publickey).
Time taken: 0 s=> ssh -n -oBatchMode=yes mkdir -p /work/n02/n02/myosh/um/tfkqy/baserepos/UMATMOS/cfg
[FAIL] ssh -n -oBatchMode=yes mkdir -p /work/n02/n02/myosh/um/tfkqy/baserepos/UMATMOS/cfg failed (255) at /home/fcm/fcm-2019.09.0/bin/…/lib/FCM1/ line 755.

I think this is most related to the topic
But it has been closed and don’t seem to be able to be reopened.

In that topic I tried to set up a connection from pumanew to ARCHER2, and it seemed to have gone in the way shown in the instruction at

It is still the case. When I do this

$ ssh

I get these, which are exactly the same response that is shown near the bottom of that page;

Enter passphrase for key ‘/home/ggxmy/.ssh/id_rsa_archerum’:
PTY allocation request failed on channel 0
Comand rejected by policy. Not in authorised list
Connection to closed.

Can anyone see what’s the problem? Or any suggestion for what I can try?

Here is another and probably a minor issue. Can’t I change directory to /work on ARCHER2? I don’t seem to be able to do that.

myosh@ln01:/home/n02/n02/myosh $ cd /work/n02/n02/myosh
myosh@ln01:/home/n02/n02/myosh $ pwd

although I can see the directory;

myosh@ln01:/home/n02/n02/myosh $ ll /work/n02/n02/myosh/um
total 4
drwxr-sr-x 3 myosh n02 4096 Nov 17 14:06 tfkqz

So, although I wasn’t aware, it seems that the submission of my previous job (tfkqz) has come through to ARCHER2 on Nov 17 (tfkqy did not come through).


Hi Masaru,

  1. With regard to your connection from pumanew to archer2. It looks like you haven’t added your ~/.ssh/id_rsa_archerum key to your ssh-agent or the agent has since died. When you run ssh you should not be prompted for any input, this includes a password or passphrase. Please run ssh-add ~/.ssh/id_rsa_archerum and then check you are no longer prompted for any input.

  2. Tickets can’t be reopened after a certain time period. Just link to them as you have done.

  3. I can cd to your work directory ok:

    ARCHER2-23cab> cd
    ARCHER2-23cab> pwd
    ARCHER2-23cab> cd /work/n02/n02/myosh
    ARCHER2-23cab> pwd

Looking in your ~/.bashrc file you have a whole host of command aliases setup including one that redefines the functionality of cd!

  1. Before you run umui jobs you will need to set up a couple things first. See the initial setup section here: Running UMUI Jobs on ARCHER2


Thank you, Ros.

Regarding the 3rd point, that alias is just to record the current directory so I can go back and forth between directories, and in the end it does ‘/cd’. It works everywhere else, but does not seem to work on ARCHER2 for some reason. So I disabled it.

  1. I think I did everything that applies.

Regarding the first and main issue, you are right. I should have repeated “ssh-add ~/.ssh/id_rsa_archerum”.
When I set up, I read “The ssh-agent will continue to run even when you log out of PUMA, however, it may stop from time to time, for example if PUMA is rebooted.” but forgot about it.

So I tried to submit the job, and quite naturally it didn’t go without a problem, but I’m at the different place now. The new problem may related to this one so I’ll keep this topic open for a while.

Thank you very much for your help anyway.