Unable to connect to Met-Office respository


I run UKCA / UKESM v11.1 on ‘ARCHER2’ and use ‘pumanew’ for job submission. I have modified my branch and tried to commit it using ‘fcm commit’ but I am getting an error. I tried ‘mosrs-cache-password’ that too is also not working. Although I am able to login to the web version of the Met-Office repository management system. I have had modified my password a few weeks ago. The error message is the following:

-bash-4.2$ fcm commit
[FAIL] svn status --ignore-externals --show-updates # rc=1
[FAIL] svn: E170013: Unable to connect to a repository at URL ‘https://code.metoffice.gov.uk/svn/um/main/branches/dev/alokpandey/vn11.1_DEST_plus_Iodine_akp_B
[FAIL] svn: E215004: No more credentials or we tried too many times.
[FAIL] Authentication failed

-bash-4.2$ mosrs-cache-password
gpg-agent: no process found
Error: gpg-agent not working
Run “mosrs-cache-password” to try caching your password again

How can I fix this issue?

Regards, Alok

Hi Alok,

Looking in your .profile and .bashrc there is none of the setup in there for mosrs-cache-password to work.

Please add the following lines to the bottom of your ~/.bashrc file on PUMA.

# Setup for MOSRS
[[ "$-" != *i* ]] && return # Stop here if not running interactively
. mosrs-setup-gpg-agent

Then log out of PUMA and back in again. It should start up a new gpg-agent process and prompt for your MOSRS password.

One thing to note: If you have some symbols in your MOSRS password like ^, # these won’t work. !, $ are known to be ok.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.