Unable to create a branch

Dear CMS help desk,

I have been trying to create a branch in the MET office repository and I have created a ticket for it. However I still can not create it. The error message is
[FAIL] svn info --xml https://code.metoffice.gov.uk/svn/jules/main/trunk@24333 # rc=1
[FAIL] svn: E170013: Unable to connect to a repository at URL ‘https://code.metoffice.gov.uk/svn/jules/main/trunk
[FAIL] svn: E215004: No more credentials or we tried too many times.
[FAIL] Authentication failed
I can copy a branch to my local environment no problem. Could you take a look.

Have you set up caching of your MOSRS credentials?

Which machine is this on?


Hi Wenyao:
What command are you trying to use that generates the error message?
Is this on JASMIN?
Is it on the cylc1 Virtual Machine of JASMIN?

I had trouble caching my MOSRS password earlier today on cylc1 on JASMIN. It wouldn’t ask me for an MOSRS password when I logged in to cylc1. Does it ask you for an MOSRS password?
If it doesn’t ask for an MOSRS password, then in order to fix this, I needed to kill and restart my gpg-agent by doing this:

  1. ssh to cylc1
  2. ps -elf | grep $USER
  3. search for the PID of gpg-agent
  4. kill -9 PID
    (where PID is the the PID of the gpg-agent)
  5. log out of cylc1 and log back in. It should now ask for a MOSRS password.

Does this help?
Patrick McGuire

Dear Patrick,

Thanks for your help. This has been solved. I firstly tried . mosrs-setup-gpg-agent and it is caching ok. But the problem still exists. Then I tried the mosrs-cache-password together. The problem does not pop up again.


it happened when I tried to create a branch as well as ‘fcm commit’ on the cylc1 on login2.

Hi Wenyao
Well, if the problem went away, as you say, then it was some sort of temporary internal problem.
But if it does come back, then let us know.