Coupled UKESM1.0 vn11.2 suite failing in fcm_make2_ocean and fcm_make2_drivers

Dear CMS Modelling Helpdesk,

I have copied a coupled atmosphere-ocean suite (u-bg743@135986) from Luke Abraham which was run several years ago. I am trying to run the new suite (u-ch175) on the XCS-C, but at the moment it is failing at the fcm_make2_ocean and fcm_make2_drivers step. fcm_make_um completes successfully. The error is below:

[FAIL] no configuration specified or found

[FAIL] fcm make -C /var/spool/jtmp/8046071.xcs00.Yml7bK/fcm_make2_ocean.19500101T0000Z.u-ch1751xixvo -n 2 -j 6 # return-code=2
2021-08-16T14:52:30Z CRITICAL - failed/EXIT

Luke and I have looked through the error messages and previous tickets, and the error looks a lot like an error seen in previous tickets:

However, I’ve followed some of the suggested changes in those tickets (which revolve around the specification of the host name in the MONSooN.rc file), but the suite continues to fail at the same point. I have added the following lines to the [[HPC_SERIAL]] and [[OCEANBUILD_RESOURCE]] blocks:
host = xcs-c
and also tried localhost instead of xcs-c, but the same error message occurs.

Can you advise on how to resolve this error? Please let me know if there is any further information I can provide.


Hi James

Your suite worked OK for for me - did you rose suite-run --new?

Note: /home/d03/jkeeb/roses/u-ch175/rose-suite.conf should just start with




assuming you want output to go to ukca-cam.


Thanks for this Grenville.

Note that the format for the root-dir lines was taken directly from the Monsoon2 documentation here:


Thanks for pointing out that link Luke. I’ll ask Veryan to fix that as it is out of date.


Hi Grenville,

Thanks for this, and apologies for the mistake. When I made the changes to the MONSooN.rc file I ran rose suite-run --reload, and it must have not picked up the change. Having now run rose suite-clean and then restarting the suite it has run past the fcm_make2_ocean and fcm_make2_drivers step, but is stopping at all tasks starting with ‘coupled’, which are listed as retrying. From your message above the version of the suite you ran got past this step?


PS, I have updated the root-dir=*=/projects/ukca-cam/$USER line, thanks for spotting that. As Luke says, we took the pair of lines from Monsoon2 documentation Luke has linked to.


The error file says
Error message: Unable to find file id (pp201) in portio or netcdf file lists
The stash setup says UPN is associated with file_id pp201, but there is no associated output stream (same goes for UPO, UPP, UOQ, and UPR.)

Maybe add new output streams, or move stash into usage profiles that are set up correctly.


Thanks Grenville - I tried to duplicate the STASH from another suite and must have missed the output streams. I’ll fix that now. Happy for you to mark the original issue as resolved. Thanks again!