Creating UM branch for use in UKESM1

I am trying to make some changes to add a new species and emissions to UKESM1 on ARCHER2 using the suite u-be303/archer2 (which for me on PUMA is suite u-ch249,and runs fine with vanilla settings). To do this I need to make a branch of UM vn11.1. To do this, do I need to create a branch of the trunk UM (ie fcm branch-create -k <branch_name> fcm:um.x-tr@vn11.1) and add this as a source and then make changes, or is it best to create a branch from one of the branches that is already in use in the suite (ie fcm branch-create -k <branch_name> fcm:um.x-br@vn11.1/dev/branches/dev/jeffcole/vn11.1_archer2_fixes) and then replace this with my new branch?

Hi Liam

Creating a branch from the trunk is probably best. That may need a rethink if you make changes that conflict with changes in the other branches.


Ok, I’ll give that a go and see if I can get it to work without conflict.



So I have created a branch of UM and have added a new species in the method described in UKCA Chemistry and Aerosol vn11.8 Tutorial 4 - UKCA, and the first step is to change the meta setting of the um app to /path/to/vn11.8_your_branch_name/rose-meta/um-atmos/HEAD, which I try to do with my new branch of UM vn11.1, however I get a error within rose that it cannot find the metadata for this branch (as seen in fig). Is the way to add a new species different to the method described in the UKCA tutorial when using PUMA and ARCHER2?

Hi Liam,

You’re using a relative path for the metadata. While using branches/dev/liamblyth/... etc is correct to use a UM branch from the MOSRS repository in the make process, you need to use an absolute path on PUMA or Monsoon2 for the metadata, as Rose needs to be able to read this when it’s opened up.

The shorthand /path/to/... means the path on the server where you have checked your branch out to, e.g. something like /home/... etc. (note the initial /, which will mean a local path).

Best wishes,


Thanks, that seems to have worked, and the suite will run when using the new meta, however I now have an issue with the input dump. When I add my new species to STASHmaster as s34i498 the suite then fails on recon stage with several error that look like:

???!!!???!!!???!!!???!!!???!!! ERROR ???!!!???!!!???!!!???!!!???!!!
? Error code: 30
? Error from routine: RCF_RESET_DATA_SOURCE
? Error message: Section 34 Item 498 : Required field is not in input dump!
? Error from processor: 19
? Error number: 24

which I assume means that my new species has no input files. However when I try to initialise the tracer by going to UM → namelist → Reconfigure and Ancillary Control → Configure ancils and initialise dump fields and setting the initial value to a small constant value it is not a option. I figure if the model is failing like this is must be seeing the correct STASHmaster file, however I don’t seem to be able to set up the initialisation. Is this the right way to add the new species?

Thanks for the help,