Problems converting coupled GA8 suite to use CoMorph-A


I am modifying a UM vn12.1 regional KPP-coupled suite from GA8 to use the CoMorph-A convection scheme (suite u-db390). I have applied these changes in a CoMorph-A options file, created by merging app/coupled/opt/rose-app-ga8.conf with an option file from suite u-cl223 (app/ga_scm/opt/rose-app-CoMorphA.conf), as described by this GMED ticket:

The model compile and reconfigures OK, however task tm_comorphA_um_fcst1 fails with the following error in the coupler:

???!!!???!!!???!!!???!!!???!!! ERROR ???!!!???!!!???!!!???!!!???!!!
? Error code: 1
? Error from routine: OASIS_INITA2O
? Error message:
? 2 item(s) missing from STASH coupling fields.
? Please refer to standard output for full details.
? Error from processor: 0
? Error number: 61

The missing fields are convective rain (Sec 5, Itm 205) and convective snow (Sec 5, Itm 206). Tracing the error back through the job.out file, there are multiple warnings for stash requests that are “Unavailable to this model version.” These warnings include convective rain and snow, but also many other variables, including those which have no associated STASH request! For example

??? WARNING ???
? Warning code: -30
? Warning from routine: PRELIM_MOD:PRELIM
? Warning message:
? Field - Section:0, Item:431 request denied.
? Unavailable to this model version.
? Warning from processor: 0
? Warning number: 25

Could you help me to understand this error and how to fix it? Note that running the suite with the GA8 option file produces none of the warnings, so the failure definitely arises from the CoMorph-A opt file.

Many thanks,

Hi Dan

OASIS expects a particular set of coupling fields to be made available - I guess comorph doesn’t provide the field with the expected stash code. The coupled KPP model can be modified to understand comorph but that might involve significant effort. Have you seen how comorph is handled in a coupled model that uses NEMO (I’m assuming there is one)?


Hi Grenville,

Sorry for the delay getting back to you.

I’ve checked with Mike Whitall and Adrian Lock, and CoMorph does provide all the relevant fields (convective rain (Sec 5, Itm 205) and convective snow (Sec 5, Itm 206)), despite the model output saying they are unavailable. What makes me suspicious about the setup is that I also get warnings for STASH requests that I haven’t actually made. This sort of error is new to me – have you any idea how I might go about debugging it?

Many thanks,

Hi Dan,

I’ve had a look at your job, and I think the issue is that you’re
using a vn11.4
STASHmaster_A file, input from work/n02/n02/emmah/um_input/um_STASHmaster
Comorph doesn’t appear to be configured for this version.
This is set in site/cas-cray-ex/suite-adds.rc

You need to use a 12.1 stashmaster to ensure that comorph fields are


Hi Simon,

Thanks! I’ve got the model running now after updating the STASHmaster_A file (and other associated files) to the vn12.1 trunk version.

However I still get “Unavailable to this model version” warnings for 6 variables (Sec 0, Items 431-436), none of which I actually make STASH requests for in the suite config. While it doesn’t stop the model from running, I’d still like to get to the bottom of the warnings. Have you any idea how to go about debugging this?

Many thanks,

Hi Dan,

Glad it worked. The 431-436 fields are part of the MakeBC STASH package
and are set in
opt/rose-app-lbc.conf file. As you have the lbc optional key
configured somewhere in the
suite, then this .conf file will be used. You can see that the lbc
optional key is set by looking
at the job.out file.


Hi Simon,

Great! Thank you for the explanation.

I have found a new problem – the suite I’m basing the CoMorph runs on used UM vn11.4, and used the convpp utility to convert FieldsFiles to PP in the postprocessing step. Convpp was retired in vn11.6; is there a guide on how to modify old suites to use the new Mule functionality? I’ve had a scan through the UM documentation and a search for “convpp” on the CMS helpdesk but can’t find anything obvious.

Many thanks,

Ignore my previous comment – turns out it was quite easy to do by inspecting a newer suite!

Thanks to both Grenville and Simon for all of your help on this.

Best wishes,

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.