Error: Ancillary files have not been found


My vn12.0 nesting suite u-cs159 is getting this error. I recreated ancillary files but the error doesn’t seem to go away.

? Error code: 10
? Error from routine: CALC_NLOOKUPS
? Error message: Ancillary files have not been found - Check output for details
? Error from processor: 0
? Error number: 4

Any idea?


Hi Masaru

I regularly get this error when something is expected by the recon but not found (or misnamed) in the ancil directory. You can check which files the suite is complaining about by looking at the .out file (you can search for the line “does not exist” to save you scrolling through all the output)


Hi Ella,

Thanks. That’s right. I thought I checked job.out but wasn’t really looking…

So in my case, this file does not exist.

Do you know how I make the model create it?


Hey Masaru
There should be a few switches under the region 1 tab on the nesting suite that has a few options to create additional ancils. Something like rg01_rs01_3D_ancils ?

Does your suite use the soil.dust ancil directly? If not, you can just ask the model to skip over that particular file… Sometimes I find that a quick solution to test if there are any other problems.

Hi Ella,

Thanks. This is my current settings near the bottom of ‘Resolution 1 setup’ tab.

This is a regional simulation centred at Iceland to see the effects of volcanic aerosols on clouds. I started the simulations with prognostic dust turned off, just to avoid this problem, but I think dust from Iceland can be important.

(This should be an answer to your second question. Dust must use soil.dust ancil.)

On the other hand, dust is currently simulated in CLASSIC bin scheme and is not treated in UKCA and hence its effects on clouds will not be simulated anyway (sorry these are more about science).

To turn on dust in regional high-resolution simulations, I now think I should turn on ANTS to give a high-resolution surface boundary condition. And I guess that may be related to this problem.

The suite does not create the soil.dust ancillary possibly because of the resolution (2.5km), which is too small compared to the global model (n216) where the regional ancils are derived and downscaled (with ANTS turned off)? This is only my guess and can be wrong. There may be a simple switch.

Anyway, I will keep my simulation running for now with dust and ANTS turned off. I may come back to this issue later.

Meanwhile if you have any suggestions, comments or ideas please share them with me.


Ooh, I’m not sure about that then. I’ve definitely managed to make a soil.dust file before, but I can’t remember how! Is the soil.dust very different to .dust? if not, and/or if not that important, you could try and cheat it for now by simply pointing to the .dust file…?