Error of running suite u-cc654 of UM training course

Hello,

I got an error message when I ran suite u-cc654 following 5.1 in the online UM training course. The full error message is as follows:

*[FAIL] config-file=/home4/home/n02-puma/xuang/cylc-run/u-dh358/work/19880901T0000Z/fcm_make_um/fcm-make.cfg:2*
*[FAIL] config-file= - [ https://code.metoffice.gov.uk/svn/um/main/branches/dev/simonwilson/vn11.7_archer2_compile/fcm-make/ncas-ex-cce/um-atmos-safe.cfg](https://code.metoffice.gov.uk/svn/um/main/branches/dev/simonwilson/vn11.7_archer2_compile/fcm-make/ncas-ex-cce/um-atmos-safe.cfg)*
*[FAIL] [ https://code.metoffice.gov.uk/svn/um/main/branches/dev/simonwilson/vn11.7_archer2_compile/fcm-make/ncas-ex-cce/um-atmos-safe.cfg](https://code.metoffice.gov.uk/svn/um/main/branches/dev/simonwilson/vn11.7_archer2_compile/fcm-make/ncas-ex-cce/um-atmos-safe.cfg): cannot load config file*
*[FAIL] [ https://code.metoffice.gov.uk/svn/um/main/branches/dev/simonwilson/vn11.7_archer2_compile/fcm-make/ncas-ex-cce/um-atmos-safe.cfg](https://code.metoffice.gov.uk/svn/um/main/branches/dev/simonwilson/vn11.7_archer2_compile/fcm-make/ncas-ex-cce/um-atmos-safe.cfg): not found*
*[FAIL] svn: E170013: Unable to connect to a repository at URL 'https://code.metoffice.gov.uk/svn/um/main/branches/dev/simonwilson/vn11.7_archer2_compile/fcm-make/ncas-ex-cce/um-atmos-safe.cfg'*
*[FAIL] svn: E215004: No more credentials or we tried too many times.*
*[FAIL] Authentication failed*
*[FAIL] fcm make -f /home4/home/n02-puma/xuang/cylc-run/u-dh358/work/19880901T0000Z/fcm_make_um/fcm-make.cfg -C /home/n02/n02/xuang/cylc-run/u-dh358/share/fcm_make_um -j 4 mirror.target=ln02:cylc-run/u-dh358/share/fcm_make_um mirror.prop{config-file.name}=2 # return-code=1*
*2024-07-03T13:01:58Z CRITICAL - failed/EXIT*

Since I do not have the access to UM documentation in MOSRS, my colleague helps me check whether the folder exists or not, and the answer is yes. I tested the suite u-cc519 again, which runs well, indicating I have the access to different UM branches.

Now I have no clue about how to solve it. Please give a hand. Thank you.

Cheers

Xu

Hi Xu,

The difference between u-cc519 and u-cc654 is that the first one extracts the code from the mirrors stored on PUMA2 and the second takes the codes direct from the Met Office UM repository on MOSRS.

So you need to get your access to the UM repository sorted out so you can see https://code.metoffice.gov.uk/trac/um/.

Have you emailed the Scientific Partnerships team as advised in your other ticket?

Then you need to follow the puma2 setup instructions to ensure your MOSRS password is cached. See Access to UM documentation - #2 by grenville

In the meantime you could switch your copy of u-cc654 to use the read-only code mirrors:
In fcm_make_um ā†’ env ā†’ configuration file change config_root_path to be fcm:um.xm-br/dev/simonwilson/vn11.7_archer2_compile.

Regards,
Ros.

Hi Ros

Thanks for the prompt solution, which works now.

Yes, I have reported the access issue to Scientific Partnerships last Friday. Iā€™m going to hassle them again.

Best

Xu