Re-running suite from scratch


I tried running a short test run of u-cv789 last week, but it failed as I ran out of space on Archer2. It seemed to produce far larger files than I was expecting, including a lot of UKCA files. I thought it was worth trying to switch off UKCA (suite conf → nesting suite → General run options: USE_UKCA to false) and then deleted the first test run. To do this, I went to /work/n02/n02/arm33/cylc-run and deleted the u-cv789 directory. When I tried re-running the suite, however, it failed.

The job.err is:

Is this something to do with maybe not deleting everything I needed to? Do I need to delete cylc-run/u-cv789 on puma too if I want to re-run from scratch?

I should point out that I’ve had ancil problems before when re-running nesting suites, and used the method that Declan describes here (Problem with ancillary file) to set the ancils under ANCIL_CAP to ‘succeded’, which could also be the problem?



I’d not recommend switching off UKCA - safer to stop the model writing out so much data through STASH changes, but that’s clearly not related to the ancil problem.

If you are happy to start from scratch, then, in the suite directory
rose suite-run --new
will remove all files and start over - I’d try that.