V8.4 UM-UKCA job giving FCM extract error on PUMAnew

Dear NCAS-CMS support team,

I am trying to run some Hunga-Tonga simulations for a Univ. Colorado co-ordinated Tonga-MIP,
to run with GA4 UM-UKCA matching the code-base we used for the Pinatubo simulations we published in Dhomse et al. (2020) and Quaglia et al. (2022) – but following the protocol for the experiments, to run with nudging to re-analysis etc.

This I got 99% of the way there on PUMA-test, but the jobs I was running fine there, seem not to be working when I submit from on the new PUMAnew system.

I’m getting a basic FCM extract error when submitting the job.

It’s giving a “revision keyword not defined” error message re: the JULES FCM extract, and I remember getting this error message previously, possibly when the system similarly moved to a new PUMA server in the past.

I seem to recall we had to run an initial command, so that the model run could access the FCM repository for JULES etc. on the new PUMA server machine.

The ssh keys etc. are all set up fine, but when it extracts from the FCM branches to build the codebase, it’s giving an FCM extract error saying “revision keyword not found”

When I check the JULES/ext.out log file

Extract command started on Sun Dec 4 13:27:34 2022.
->Parse configuration: start
Config file (ext): svn://pumanew/UM_svn/UM/branches/dev/um/vn8.4_machine_cfg/src/configs/bindings/container.cfg@22831
Config file (ext): svn://pumanew/UM_svn/UM/branches/dev/um/vn8.4_machine_cfg/src/configs/bindings/JULES_repos.cfg@22831
Config file (ext): svn://pumanew/UM_svn/UM/branches/dev/um/vn8.4_machine_cfg/src/configs/machines/init_options.cfg@22831
Config file (ext): svn://pumanew/UM_svn/UM/branches/dev/um/vn8.4_machine_cfg/src/configs/machines/cray-xc30-cce-archer/machine.cfg@22831
Config file (ext): svn://pumanew/UM_svn/UM/branches/dev/um/vn8.4_machine_cfg/src/configs/machines/cray-xc30-cce-archer/ext_libs/default_paths.cfg@22831
Config file (ext): /dev/null
Config file (ext): svn://pumanew/UM_svn/UM/branches/dev/um/vn8.4_machine_cfg/src/configs/machines/cray-xc30-cce-archer/ext_libs/gcom_mpp.cfg@22831
Config file (ext): svn://pumanew/UM_svn/UM/branches/dev/um/vn8.4_machine_cfg/src/configs/machines/cray-xc30-cce-archer/ext_libs/gcom_serial.cfg@22831
Config file (ext): /dev/null
Config file (ext): /dev/null
Config file (ext): /dev/null
->Parse configuration: 1 second
->Setup destination: start
Destination: gmann@pumanew.novalocal:/home/gmann/um/um_extracts/xplpg/baserepos/JULES
/home/gmann/um/um_extracts/xplpg/baserepos/JULES/.cache/.ext: remove
/home/gmann/um/um_extracts/xplpg/baserepos/JULES/cfg: remove
/home/gmann/um/um_extracts/xplpg/baserepos/JULES/src: remove
Make directory: /home/gmann/um/um_extracts/xplpg/baserepos/JULES/.cache/.ext
Make directory: /home/gmann/um/um_extracts/xplpg/baserepos/JULES/cfg
Make directory: /home/gmann/um/um_extracts/xplpg/baserepos/JULES/src
Generated ext cfg: /home/gmann/um/um_extracts/xplpg/baserepos/JULES/cfg/parsed_ext.cfg
->Setup destination: 0 second
->Extract: start
[FAIL] https://pumatest.nerc.ac.uk/svn/JULES_svn/JULES/trunk@um8.4: revision keyword not defined

Please can you advise, am I correct that there’s a command I need to run on the new PUMA machine so that the JULES extract refers to pumanew rather than pumatest?

That’s clearly the error, it’s trying to extract the JULES repository from pumatest.nerc.ac.uk, when it needs to extract this from pumanew.nerc.ac.uk

I’ll check the old NCAS CMS helpdesk system, to see if I can track down a query on that old system that refers to the command I recall we had to run there for the system to know it had changed from pumatest to pumanew.


From: ncas-puma-umui-bounces@lists.reading.ac.uk ncas-puma-umui-bounces@lists.reading.ac.uk on behalf of Rosalyn Hatcher r.s.hatcher@reading.ac.uk
Date: Tuesday, 15 September 2015 at 11:31
To: Dalvi, Mohit mohit.dalvi@metoffice.gov.uk
Cc: ncas-puma-umui@lists.reading.ac.uk ncas-puma-umui@lists.reading.ac.uk
Subject: Re: [Ncas-puma-umui] Problems accessing Jules_svn (for fcm extract).
Hi Mohit,

I think this is due to the apache certificate on PUMA expiring last night. We will hopefully get this fixed later today.


On 15 Sep 2015, at 11:27, Dalvi, Mohit mohit.dalvi@metoffice.gov.uk wrote:


I am having problems accessing the JULES repository while building an UM8.5 job.

In baserepos/JULES/ext.out:

->Extract: start
[FAIL] https://puma.nerc.ac.uk/svn/JULES_svn/JULES/trunk@um8.5: revision keyword not defined

Is this related to the MOSRS outage today ?


Mohit C. Dalvi Earth System and Mitigation Science Team
Met Office Fitzroy Road, Exeter, EX1 3PB
Telephone: +44 (0)1392 885740

See our Research pages at: http://www.metoffice.gov.uk/research

Ncas-puma-umui mailing list Ncas-puma-umui@lists.reading.ac.uk

Dear NCAS-CMS support team,

Further to my email about the FCM “revision keyword not defined”, I found a post from 2015 where Ros has replied that the problem was due to an apache certificate on PUMA expiring.

I’m guessing this is presumably the same issue, with the apache certificate referring to pumatest.nerc.ac.uk, when it needs to refer to pumanew.nerc.ac.uk?

Thanks for your help with this


Dr. Graham Mann
Lecturer in Atmospheric Science
School of Earth & Environment
University of Leeds

I saw that previously we’d been advised to run an fcm ls command
to help track down the error.

I’ve just done that from PUMAnew, and see it gives that same error message
from the command line when doing the “fcm ls” command on the JULES trunk.

Please can you advise, is it simply a case of updating the info for the FCM repository?
(Either in our environment files or, perhaps centrally via the apache certificate?)


-bash-4.2$ fcm ls fcm:jules-tr

svn: E170013: Unable to connect to a repository at URL ‘https://pumatest.nerc.ac.uk/svn/JULES_svn/JULES/trunk

svn: E000113: Error running context: No route to host

[FAIL] svn list https://pumatest.nerc.ac.uk/svn/JULES_svn/JULES/trunk # rc=1

Hi Graham,

Sorry, the old JULES repository slipped through the net. I’ve now reconfigured it and it is available for use again.


(CMS Admin Note: Repository reconfigured from https:// to svnserve)

Hi Ros,
OK, great – thanks a lot.

To confirm, I’ve just tried re-submitting the test xplp-g job again, and it submitted fine this time.

Thanks again,

Best regards,